summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild')
-rw-r--r--dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
new file mode 100644
index 000000000000..d8127f9e0c3e
--- /dev/null
+++ b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Unicode Support version of Text.Regex, using regex-tdfa"
+HOMEPAGE="http://hub.darcs.net/shelarcy/regex-compat-tdfa"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+newbase +splitbase"
+
+RDEPEND=">=dev-haskell/regex-base-0.93:=[profile?]
+ >=dev-haskell/regex-tdfa-1.1.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag newbase newbase) \
+ $(cabal_flag splitbase splitbase)
+}