summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/semirings/semirings-0.6.ebuild')
-rw-r--r--dev-haskell/semirings/semirings-0.6.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-haskell/semirings/semirings-0.6.ebuild b/dev-haskell/semirings/semirings-0.6.ebuild
deleted file mode 100644
index dd5a71e5ad8a..000000000000
--- a/dev-haskell/semirings/semirings-0.6.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.7.1.1.9999
-#hackport: flags: +containers,+unordered-containers
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-CABAL_HACKAGE_REVISION="1"
-inherit haskell-cabal
-
-DESCRIPTION="two monoids as one, in holy haskimony"
-HOMEPAGE="https://github.com/chessai/semirings"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
- https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-
-RDEPEND="dev-haskell/base-compat-batteries:=[profile?]
- >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
- >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
- >=dev-lang/ghc-8.4.3:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
-"
-BDEPEND="app-text/dos2unix"
-
-src_prepare() {
- # pull revised cabal from upstream
- cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
-
- # Convert to unix line endings
- dos2unix "${S}/${PN}.cabal" || die
-
- # Apply patches *after* pulling the revised cabal
- default
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=containers \
- --flag=unordered-containers
-}