summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/sha/sha-1.6.1.ebuild')
-rw-r--r--dev-haskell/sha/sha-1.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-haskell/sha/sha-1.6.1.ebuild b/dev-haskell/sha/sha-1.6.1.ebuild
new file mode 100644
index 000000000000..acbf113ad97f
--- /dev/null
+++ b/dev-haskell/sha/sha-1.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="SHA"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Implementations of the SHA suite of message digest functions"
+HOMEPAGE="http://hackage.haskell.org/package/SHA"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND="dev-haskell/binary:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"