summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/skylighting/skylighting-0.10.2.ebuild')
-rw-r--r--dev-haskell/skylighting/skylighting-0.10.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/skylighting/skylighting-0.10.2.ebuild b/dev-haskell/skylighting/skylighting-0.10.2.ebuild
new file mode 100644
index 000000000000..69413875bb52
--- /dev/null
+++ b/dev-haskell/skylighting/skylighting-0.10.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -bootstrap,+system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND="~dev-haskell/skylighting-core-0.10.2:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+ executable? ( >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/pretty-show:=[profile?]
+ dev-haskell/text:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bootstrap \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}