summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/texmath/texmath-0.8.0.2.ebuild')
-rw-r--r--dev-haskell/texmath/texmath-0.8.0.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/texmath/texmath-0.8.0.2.ebuild b/dev-haskell/texmath/texmath-0.8.0.2.ebuild
new file mode 100644
index 000000000000..a45ea7327326
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.8.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between formats used to represent mathematics"
+HOMEPAGE="http://github.com/jgm/texmath"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable +network-uri"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.12.3.3:=[profile?]
+ >=dev-haskell/parsec-3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ executable? ( dev-haskell/aeson:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/text:=[profile?] )
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/temporary
+ dev-haskell/utf8-string
+ !executable? ( dev-haskell/split
+ dev-haskell/text ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag network-uri network-uri)
+}