summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/th-lift-instances')
-rw-r--r--dev-haskell/th-lift-instances/Manifest1
-rw-r--r--dev-haskell/th-lift-instances/metadata.xml12
-rw-r--r--dev-haskell/th-lift-instances/th-lift-instances-0.1.11.ebuild28
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/th-lift-instances/Manifest b/dev-haskell/th-lift-instances/Manifest
new file mode 100644
index 000000000000..321a9a985651
--- /dev/null
+++ b/dev-haskell/th-lift-instances/Manifest
@@ -0,0 +1 @@
+DIST th-lift-instances-0.1.11.tar.gz 4477 SHA256 1da46afabdc73c86f279a0557d5a8f9af1296f9f6043264ba354b1c9cc65a6b8 SHA512 e4e443637c10cd21d9b6159f29ad8eb61a65bda2b625dff48ccbf1310c9abdbb1f48ff0c7e74974b78e0517db6af2889abb3c5cfeaed202c7b3efbe1c83dbc7a WHIRLPOOL 4d73b70d03c4c9a3cc888814fdcf05f1c4ea5b9479155d666a28afa5dcdfb5aec5aa4738d8dbf4274b8d163651d3a979670b26ad78473c133ffabb470765347c
diff --git a/dev-haskell/th-lift-instances/metadata.xml b/dev-haskell/th-lift-instances/metadata.xml
new file mode 100644
index 000000000000..0d764dc95edd
--- /dev/null
+++ b/dev-haskell/th-lift-instances/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Most data types in haskell platform do not have Lift instances. This package provides orphan instances
+ for containers, text, bytestring and vector.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/th-lift-instances/th-lift-instances-0.1.11.ebuild b/dev-haskell/th-lift-instances/th-lift-instances-0.1.11.ebuild
new file mode 100644
index 000000000000..5213fdf2b696
--- /dev/null
+++ b/dev-haskell/th-lift-instances/th-lift-instances-0.1.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Lift instances for template-haskell for common data types"
+HOMEPAGE="https://github.com/bennofs/th-lift-instances/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/text:=[profile?]
+ dev-haskell/th-lift:=[profile?]
+ >=dev-haskell/vector-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.6 )
+"