summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/unixutils/unixutils-1.54.1.ebuild')
-rw-r--r--dev-haskell/unixutils/unixutils-1.54.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/unixutils/unixutils-1.54.1.ebuild b/dev-haskell/unixutils/unixutils-1.54.1.ebuild
new file mode 100644
index 000000000000..3fdfa355249e
--- /dev/null
+++ b/dev-haskell/unixutils/unixutils-1.54.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Unixutils"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A crude interface between Haskell and Unix-like operating systems"
+HOMEPAGE="https://github.com/seereason/haskell-unixutils.git"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/exceptions:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/process-extras-0.3:=[profile?]
+ dev-haskell/puremd5:=[profile?]
+ dev-haskell/regex-tdfa:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ virtual/libc
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"