summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/unordered-containers/unordered-containers-0.2.7.0.ebuild')
-rw-r--r--dev-haskell/unordered-containers/unordered-containers-0.2.7.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/unordered-containers/unordered-containers-0.2.7.0.ebuild b/dev-haskell/unordered-containers/unordered-containers-0.2.7.0.ebuild
new file mode 100644
index 000000000000..0f25c0f83619
--- /dev/null
+++ b/dev-haskell/unordered-containers/unordered-containers-0.2.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient hashing-based container types"
+HOMEPAGE="https://github.com/tibbe/unordered-containers"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-haskell/hashable-1.0.1.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/chasingbottoms
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4.0.1
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}