summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hdbc-sqlite3/Manifest (renamed from dev-haskell/hdbc-sqlite/Manifest)0
-rw-r--r--dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild (renamed from dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.1.ebuild)30
-rw-r--r--dev-haskell/hdbc-sqlite3/metadata.xml (renamed from dev-haskell/hdbc-sqlite/metadata.xml)4
-rw-r--r--dev-haskell/hdbc/hdbc-2.3.1.2.ebuild2
4 files changed, 20 insertions, 16 deletions
diff --git a/dev-haskell/hdbc-sqlite/Manifest b/dev-haskell/hdbc-sqlite3/Manifest
index 7b9e9f73b2b3..7b9e9f73b2b3 100644
--- a/dev-haskell/hdbc-sqlite/Manifest
+++ b/dev-haskell/hdbc-sqlite3/Manifest
diff --git a/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.1.ebuild b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
index 3d5d1c9d91fd..696da308bffe 100644
--- a/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.1.ebuild
+++ b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-# ebuild generated by hackport 0.4.6
+# ebuild generated by hackport 0.5.1
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="HDBC-sqlite3"
@@ -16,29 +16,29 @@ HOMEPAGE="https://github.com/hdbc/hdbc-sqlite3"
SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
-SLOT="2"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE="buildtests +splitbase"
RDEPEND=">=dev-db/sqlite-3.0
>=dev-haskell/hdbc-2.3.0.0:2=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.2.3
- test? ( dev-haskell/convertible:=[profile?]
+ buildtests? ( dev-haskell/convertible:=[profile?]
dev-haskell/hunit:=[profile?]
dev-haskell/old-locale:=[profile?]
dev-haskell/old-time:=[profile?]
dev-haskell/testpack:=[profile?] )
"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3
+"
S="${WORKDIR}/${MY_P}"
-# The test suite doesn't work right now. See
-#
-# https://github.com/hdbc/hdbc-sqlite3/pull/17
-#
-RESTRICT="test"
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildtests buildtests) \
+ $(cabal_flag splitbase splitbase)
+}
diff --git a/dev-haskell/hdbc-sqlite/metadata.xml b/dev-haskell/hdbc-sqlite3/metadata.xml
index 0bcac4dfde25..a6dc7b001d95 100644
--- a/dev-haskell/hdbc-sqlite/metadata.xml
+++ b/dev-haskell/hdbc-sqlite3/metadata.xml
@@ -5,6 +5,10 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <use>
+ <flag name="buildtests">Build the executable to run unit tests</flag>
+ <flag name="splitbase">Choose the new smaller, split-up package.</flag>
+ </use>
<longdescription>
This is the Sqlite v3 driver for HDBC, the generic
database access system for Haskell
diff --git a/dev-haskell/hdbc/hdbc-2.3.1.2.ebuild b/dev-haskell/hdbc/hdbc-2.3.1.2.ebuild
index 20bd7eecdef3..43595a5a5289 100644
--- a/dev-haskell/hdbc/hdbc-2.3.1.2.ebuild
+++ b/dev-haskell/hdbc/hdbc-2.3.1.2.ebuild
@@ -37,7 +37,7 @@ DEPENDV="$(get_version_component_range 1-2)"
PDEPEND="mysql? ( dev-haskell/hdbc-mysql )
odbc? ( =dev-haskell/hdbc-odbc-${DEPENDV}* )
postgres? ( =dev-haskell/hdbc-postgresql-${DEPENDV}* )
- sqlite? ( >=dev-haskell/hdbc-sqlite-${DEPENDV} )"
+ sqlite? ( >=dev-haskell/hdbc-sqlite3-${DEPENDV} )"
S="${WORKDIR}/${MY_P}"