summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/bsb-http-chunked/Manifest1
-rw-r--r--dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4.ebuild38
-rw-r--r--dev-haskell/bsb-http-chunked/metadata.xml17
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/bsb-http-chunked/Manifest b/dev-haskell/bsb-http-chunked/Manifest
new file mode 100644
index 000000000000..1998bde6fdfd
--- /dev/null
+++ b/dev-haskell/bsb-http-chunked/Manifest
@@ -0,0 +1 @@
+DIST bsb-http-chunked-0.0.0.4.tar.gz 6630 BLAKE2B d16b539f34518aaec4875b7644ceebbf50b94ddcdd9a2bb612dabfcd5eafbaa9753d187a5b137f39126993e0b75c9ffcebafb3772d948b45512e33ff3fae1dd9 SHA512 74c04c2fd372067c42d3631cdfc2ad7093c0c3af1145833ab307c538dbb936d2042492d4e81c520c3adde8634df29ff8558822f06f226c52d16abb4a35ab1a13
diff --git a/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4.ebuild b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4.ebuild
new file mode 100644
index 000000000000..007a3169ed00
--- /dev/null
+++ b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Chunked HTTP transfer encoding for bytestring builders"
+HOMEPAGE="https://github.com/sjakobi/bsb-http-chunked"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( dev-haskell/attoparsec
+ >=dev-haskell/blaze-builder-0.2.1.4
+ >=dev-haskell/doctest-0.8
+ dev-haskell/hedgehog
+ dev-haskell/tasty
+ dev-haskell/tasty-hedgehog
+ dev-haskell/tasty-hunit )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.8 && < 4.13' 'base >= 4.8'
+}
diff --git a/dev-haskell/bsb-http-chunked/metadata.xml b/dev-haskell/bsb-http-chunked/metadata.xml
new file mode 100644
index 000000000000..4b1a4e670b6e
--- /dev/null
+++ b/dev-haskell/bsb-http-chunked/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This library contains functions for encoding [bytestring
+ builders](http://hackage.haskell.org/package/bytestring/docs/Data-ByteString-Builder.html#t:Builder)
+ for [chunked HTTP\/1.1 transfer](https://en.wikipedia.org/wiki/Chunked_transfer_encoding).
+
+ This functionality was extracted from
+ the [blaze-builder](http://hackage.haskell.org/package/blaze-builder)
+ package.
+ </longdescription>
+</pkgmetadata>