summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/path-io/Manifest1
-rw-r--r--dev-haskell/path-io/metadata.xml11
-rw-r--r--dev-haskell/path-io/path-io-1.2.2.ebuild42
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/path-io/Manifest b/dev-haskell/path-io/Manifest
new file mode 100644
index 000000000000..7a2ed45c1181
--- /dev/null
+++ b/dev-haskell/path-io/Manifest
@@ -0,0 +1 @@
+DIST path-io-1.2.2.tar.gz 17818 SHA256 72255f9d014285c87dd4c537f445a5448b2b64e81c4ee4759464b4b0e401fe46 SHA512 910af5fd9345daa815235027992e6ab4af3784da7afa314644abaf8acb5bee59f3f1444449ce55e88961c86031cf4537c855e13ba2e777348d9fe4c0104fb6d1 WHIRLPOOL f6f62b8168d14f5ddaac4752557dda517e7224d76cfae0147e083403fff00453f3b95cdac060dee9e77c95b4f24d532a3bdce156f49cf38b3054931682ecd8c9
diff --git a/dev-haskell/path-io/metadata.xml b/dev-haskell/path-io/metadata.xml
new file mode 100644
index 000000000000..f7fb2720334b
--- /dev/null
+++ b/dev-haskell/path-io/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Interface to directory package for users of path.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/path-io/path-io-1.2.2.ebuild b/dev-haskell/path-io/path-io-1.2.2.ebuild
new file mode 100644
index 000000000000..54a64dff47ee
--- /dev/null
+++ b/dev-haskell/path-io/path-io-1.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -dev
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interface to 'directory' package for users of 'path'"
+HOMEPAGE="https://github.com/mrkkrp/path-io"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+ >=dev-haskell/path-0.5:=[profile?] <dev-haskell/path-0.6:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.3:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'time >= 1.4 && < 1.7' 'time >= 1.4'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-dev
+}