summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-junit4')
-rw-r--r--dev-java/commons-junit4/Manifest1
-rw-r--r--dev-java/commons-junit4/commons-junit4-1.2.17.ebuild39
-rw-r--r--dev-java/commons-junit4/metadata.xml10
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/commons-junit4/Manifest b/dev-java/commons-junit4/Manifest
new file mode 100644
index 000000000000..081aa48e41a9
--- /dev/null
+++ b/dev-java/commons-junit4/Manifest
@@ -0,0 +1 @@
+DIST unkrig-commons1.2.17.tar.gz 2187066 BLAKE2B 29addd6ba41edf475ff878c15a40ee328682fc7d458fae4f745e20cd00afbaa99a8f202e0d285a81a45e47177944d8dcce2e30d6f3c74d2374b46f34c5813dff SHA512 dd8652bcffd62aa847e7c36358de8eecca66f731f06da504cbdcb29f55608e384db2e0d9a7847773423d82d7ae9f3bf75e07142c95ae0ec758f15e5a3020db99
diff --git a/dev-java/commons-junit4/commons-junit4-1.2.17.ebuild b/dev-java/commons-junit4/commons-junit4-1.2.17.ebuild
new file mode 100644
index 000000000000..978b35a7b5f3
--- /dev/null
+++ b/dev-java/commons-junit4/commons-junit4-1.2.17.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="de.unkrig.commons:commons-junit4:1.2.17"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Assertions etc. for those who write tests with JUNIT 4"
+HOMEPAGE="https://unkrig.de/w/Commons.unkrig.de"
+SRC_URI="https://github.com/aunkrig/commons/archive/V${PV}.tar.gz -> unkrig-commons${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CP_DEPEND="
+ ~dev-java/commons-nullanalysis-${PV}:0
+ dev-java/junit:4
+"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CP_DEPEND}
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CP_DEPEND}"
+
+S="${WORKDIR}/commons-${PV}/commons-junit4"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
diff --git a/dev-java/commons-junit4/metadata.xml b/dev-java/commons-junit4/metadata.xml
new file mode 100644
index 000000000000..4fc465e4c3e9
--- /dev/null
+++ b/dev-java/commons-junit4/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aunkrig/commons</remote-id>
+ </upstream>
+</pkgmetadata>