summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/conversant-disruptor/conversant-disruptor-1.2.19-r1.ebuild')
-rw-r--r--dev-java/conversant-disruptor/conversant-disruptor-1.2.19-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-java/conversant-disruptor/conversant-disruptor-1.2.19-r1.ebuild b/dev-java/conversant-disruptor/conversant-disruptor-1.2.19-r1.ebuild
deleted file mode 100644
index f16f11a1f119..000000000000
--- a/dev-java/conversant-disruptor/conversant-disruptor-1.2.19-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom disruptor-1.2.19/pom.xml --download-uri https://github.com/conversant/disruptor/archive/refs/tags/1.2.19.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild conversant-disruptor-1.2.19.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="com.conversantmedia:disruptor:1.2.19"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Conversant Disruptor - very high throughput Java BlockingQueue"
-HOMEPAGE="https://github.com/conversant/disruptor"
-SRC_URI="https://github.com/conversant/disruptor/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-# Compile dependencies
-# POM: disruptor-${PV}/pom.xml
-# test? junit:junit:4.13 -> >=dev-java/junit-4.13.2:4
-# test? org.slf4j:slf4j-api:1.7.30 -> >=dev-java/slf4j-api-1.7.30:0
-
-DEPEND="
- >=virtual/jdk-11:*
- test? (
- dev-java/slf4j-api:0
- )
-"
-
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-
-S="${WORKDIR}/disruptor-${PV}"
-
-JAVA_SRC_DIR="src/main/java"
-JAVA_RESOURCE_DIRS="src/main/resources"
-
-JAVA_TEST_GENTOO_CLASSPATH="junit-4,slf4j-api"
-JAVA_TEST_SRC_DIR="src/test/java"