summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/hashcash/hashcash-1.1.ebuild')
-rw-r--r--dev-java/hashcash/hashcash-1.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/hashcash/hashcash-1.1.ebuild b/dev-java/hashcash/hashcash-1.1.ebuild
new file mode 100644
index 000000000000..155c3025dd1f
--- /dev/null
+++ b/dev-java/hashcash/hashcash-1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Generation and parsing of Hashcash"
+HOMEPAGE="https://www.nettgryppa.com/code"
+SRC_URI="https://www.nettgryppa.com/code/HashCash.java"
+
+LICENSE="GregoryRubin"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" "${S}" || die 'copy source file'
+}