summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jackson-annotations/jackson-annotations-2.13.4.ebuild')
-rw-r--r--dev-java/jackson-annotations/jackson-annotations-2.13.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-java/jackson-annotations/jackson-annotations-2.13.4.ebuild b/dev-java/jackson-annotations/jackson-annotations-2.13.4.ebuild
new file mode 100644
index 000000000000..c4e28ae651e0
--- /dev/null
+++ b/dev-java/jackson-annotations/jackson-annotations-2.13.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/FasterXML/jackson-annotations/archive/jackson-annotations-2.13.4.tar.gz --slot 2 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jackson-annotations-2.13.4.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.fasterxml.jackson.core:jackson-annotations:2.13.4"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Core annotations used for value types, used by Jackson data binding package."
+HOMEPAGE="https://github.com/FasterXML/jackson-annotations"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-11:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {README,SECURITY}.md release-notes/VERSION-2.x )
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR=( "src/main/java" "src/moditect" )
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_EXCLUDES=(
+ # 1) warning(junit.framework.TestSuite$1)
+ # junit.framework.AssertionFailedError: No tests found in com.fasterxml.jackson.annotation.TestBase
+ com.fasterxml.jackson.annotation.TestBase
+)