summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/libg')
-rw-r--r--dev-java/libg/Manifest2
-rw-r--r--dev-java/libg/libg-2.1.0-r2.ebuild48
-rw-r--r--dev-java/libg/libg-7.0.0.ebuild51
-rw-r--r--dev-java/libg/metadata.xml13
4 files changed, 58 insertions, 56 deletions
diff --git a/dev-java/libg/Manifest b/dev-java/libg/Manifest
index 068af0665527..a890570b45c8 100644
--- a/dev-java/libg/Manifest
+++ b/dev-java/libg/Manifest
@@ -1 +1 @@
-DIST bndlib-2.1.0.tar.gz 123217291 BLAKE2B ab8e6876b13db538746f77aa1fe7800e5a3b5e539e1980da78f69c64344f4964bf0a21f2329f7684b055d0de39a10c8df36e030922e9933b29fccb9a35aa669a SHA512 6965143ced45c15fc2316716de32e80506cc411d52309b24313fff37e0713a45ad200d5b3701f0d47a131a3163ec266ed8acb4544884cd1c59c9716c7a2b285e
+DIST aQute.bnd-7.0.0.tar.gz 172496438 BLAKE2B a2e443b0e4a2eb278a8e1df86456fea22ffb8147adc00c9f300cbd32b226218bb64ccca3da3bcd0d79b07567a7b4cf4456b96224d6abf59486fa08ca6170d0ba SHA512 11d34a7d1a9b2fb2e8c112d414a06c281ccde9a7b06c62043e19d83e85ea64fdf022dd4493a14dd2dcf6adee392a1e9bf1ab05a6d690a328f29d7019045bca8c
diff --git a/dev-java/libg/libg-2.1.0-r2.ebuild b/dev-java/libg/libg-2.1.0-r2.ebuild
deleted file mode 100644
index 426364b8ed10..000000000000
--- a/dev-java/libg/libg-2.1.0-r2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-JAVA_PKG_IUSE="test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Lots of small utilities for bndlib, a swiss army knife for OSGi"
-HOMEPAGE="https://bnd.bndtools.org/"
-SRC_URI="https://github.com/bndtools/bnd/archive/${PV}.REL.tar.gz -> bndlib-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-# Tests depend on biz.aQute.junit, which depends on biz.aQute.bndlib, which on
-# its own turn again depends on aQute.libg again; we can temporarily assume that
-# if bndlib tests pass that libg is sufficiently tested, in the future we should
-# look whether it is feasible to combine the packages or otherwise temporarily
-# build biz.aquite.bndlib and biz.aqute.junit in this package.
-RESTRICT="test"
-
-DEPEND=">=virtual/jdk-1.8:*"
-RDEPEND=">=virtual/jre-1.8:*"
-
-S="${WORKDIR}/bnd-${PV}.REL/aQute.${PN}"
-
-EANT_BUILD_TARGET="build"
-
-src_prepare() {
- default
- # Move the correct build.xml into place, needed for testing.
- cp ../cnf/build.xml . || die "Failed to move build file into the right place."
-
- # Remove bundled jar files.
- find . -name '*.jar' -delete
-
- # Remove test files
- if ! use test ; then
- find src/test -name '*.java' -delete || die "Failed to remove test files."
- fi
-}
-
-src_install() {
- java-pkg_newjar generated/aQute.${PN}.jar
-}
diff --git a/dev-java/libg/libg-7.0.0.ebuild b/dev-java/libg/libg-7.0.0.ebuild
new file mode 100644
index 000000000000..7acbb7965c60
--- /dev/null
+++ b/dev-java/libg/libg-7.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="biz.aQute.bnd:aQute.libg:${PV}"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A library to be statically linked. Contains many small utilities"
+HOMEPAGE="https://bnd.bndtools.org/"
+SRC_URI="https://github.com/bndtools/bnd/archive/${PV}.tar.gz -> aQute.bnd-${PV}.tar.gz"
+S="${WORKDIR}/bnd-${PV}"
+
+LICENSE="Apache-2.0 EPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+# aQute.bnd.test.jupiter does not exist
+# org.assertj.core.api.junit.jupiter does not exist
+RESTRICT="test" #839681
+
+CP_DEPEND="
+ dev-java/slf4j-api:0
+"
+
+# compile error with jdk:21, restricting to jdk:17
+# aQute.libg/src/aQute/lib/collections/SortedList.java:31: error: types List<T> and SortedSet<T> are incompatible;
+# public class SortedList<T> implements SortedSet<T>, List<T> {
+# ^
+# both define reversed(), but with unrelated return types
+# where T is a type-variable:
+# T extends Object declared in class SortedList
+DEPEND="${CP_DEPEND}
+ ~dev-java/bnd-annotation-${PV}:0
+ dev-java/osgi-cmpn:8
+ virtual/jdk:17
+"
+
+# aQute.libg/src/aQute/libg/uri/URIUtil.java:161:
+# error: switch expressions are not supported in -source 11
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-17:*
+"
+
+JAVA_AUTOMATIC_MODULE_NAME="aQute.libg"
+JAVA_CLASSPATH_EXTRA="
+ bnd-annotation
+ osgi-cmpn-8
+"
+JAVA_SRC_DIR="aQute.libg/src"
diff --git a/dev-java/libg/metadata.xml b/dev-java/libg/metadata.xml
index 94feb65b0b18..cb6317e530db 100644
--- a/dev-java/libg/metadata.xml
+++ b/dev-java/libg/metadata.xml
@@ -1,11 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <upstream>
- <remote-id type="github">bndtools/bnd</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bndtools/bnd</remote-id>
+ </upstream>
</pkgmetadata>