summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-vfs/commons-vfs-2.0-r2.ebuild72
-rw-r--r--dev-java/commons-vfs/files/commons-vfs-2.0-incompatibility.patch10
2 files changed, 76 insertions, 6 deletions
diff --git a/dev-java/commons-vfs/commons-vfs-2.0-r2.ebuild b/dev-java/commons-vfs/commons-vfs-2.0-r2.ebuild
new file mode 100644
index 000000000000..8f5598d5645b
--- /dev/null
+++ b/dev-java/commons-vfs/commons-vfs-2.0-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A single API for accessing various different file systems"
+HOMEPAGE="http://commons.apache.org/vfs/"
+SRC_URI="mirror://apache/commons/vfs/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND="
+ dev-java/ant-core:0
+ dev-java/commons-collections:0
+ dev-java/commons-logging:0
+ dev-java/commons-net:0
+ dev-java/commons-httpclient:3
+ dev-java/jackrabbit-webdav:0
+ dev-java/jsch:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-incompatibility.patch
+)
+
+S="${WORKDIR}/${P}/core"
+
+EANT_GENTOO_CLASSPATH="
+ ant-core
+ commons-collections
+ commons-logging
+ commons-net
+ commons-httpclient-3
+ jackrabbit-webdav
+ jsch
+"
+EANT_EXTRA_ARGS="-Dlibdir=${T}"
+
+# The build.xml is generated from maven and can't run the tests properly
+# Use maven test to execute these manually but that means downloading deps from
+# the internet. Also the tests need to login to some ftp servers and samba
+# shares so I doubt they work for everyone.
+#src_test() {
+# ANT_TASKS="ant-junit" eant test
+#}
+
+src_prepare() {
+ default
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ java-ant_rewrite-classpath
+ java-ant_ignore-system-classes
+}
+
+src_install() {
+ java-pkg_newjar target/*.jar
+
+ # [javadoc] No javadoc created, no need to post-process anything
+# use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java
+}
diff --git a/dev-java/commons-vfs/files/commons-vfs-2.0-incompatibility.patch b/dev-java/commons-vfs/files/commons-vfs-2.0-incompatibility.patch
index 298503ec6153..59e2f287afdd 100644
--- a/dev-java/commons-vfs/files/commons-vfs-2.0-incompatibility.patch
+++ b/dev-java/commons-vfs/files/commons-vfs-2.0-incompatibility.patch
@@ -1,6 +1,5 @@
-diff -urN a/core/src/main/java/org/apache/commons/vfs2/provider/webdav/ExceptionConverter.java b/core/src/main/java/org/apache/commons/vfs2/provider/webdav/ExceptionConverter.java
---- a/core/src/main/java/org/apache/commons/vfs2/provider/webdav/ExceptionConverter.java 2013-07-05 15:28:39.072739044 +0200
-+++ b/core/src/main/java/org/apache/commons/vfs2/provider/webdav/ExceptionConverter.java 2013-07-05 15:30:24.799404027 +0200
+--- a/src/main/java/org/apache/commons/vfs2/provider/webdav/ExceptionConverter.java 2013-07-05 15:28:39.072739044 +0200
++++ b/src/main/java/org/apache/commons/vfs2/provider/webdav/ExceptionConverter.java 2013-07-05 15:30:24.799404027 +0200
@@ -50,7 +50,7 @@
{
try
@@ -10,9 +9,8 @@ diff -urN a/core/src/main/java/org/apache/commons/vfs2/provider/webdav/Exception
if (DomUtil.matches(error, DavException.XML_ERROR, DavConstants.NAMESPACE))
{
if (DomUtil.hasChildElement(error, "exception", null))
-diff -urN a/core/src/main/java/org/apache/commons/vfs2/provider/webdav/WebdavFileObject.java b/core/src/main/java/org/apache/commons/vfs2/provider/webdav/WebdavFileObject.java
---- a/core/src/main/java/org/apache/commons/vfs2/provider/webdav/WebdavFileObject.java 2013-07-05 15:28:39.072739044 +0200
-+++ b/core/src/main/java/org/apache/commons/vfs2/provider/webdav/WebdavFileObject.java 2013-07-05 15:31:02.449403426 +0200
+--- a/src/main/java/org/apache/commons/vfs2/provider/webdav/WebdavFileObject.java 2013-07-05 15:28:39.072739044 +0200
++++ b/src/main/java/org/apache/commons/vfs2/provider/webdav/WebdavFileObject.java 2013-07-05 15:31:02.449403426 +0200
@@ -63,6 +63,7 @@
import org.apache.jackrabbit.webdav.client.methods.UncheckoutMethod;
import org.apache.jackrabbit.webdav.client.methods.VersionControlMethod;