summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/c-intercal')
-rw-r--r--dev-lang/c-intercal/c-intercal-30.0.ebuild9
-rw-r--r--dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch17
2 files changed, 23 insertions, 3 deletions
diff --git a/dev-lang/c-intercal/c-intercal-30.0.ebuild b/dev-lang/c-intercal/c-intercal-30.0.ebuild
index 8c0b34dc7738..374b59209641 100644
--- a/dev-lang/c-intercal/c-intercal-30.0.ebuild
+++ b/dev-lang/c-intercal/c-intercal-30.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -33,14 +33,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="emacs examples"
-DEPEND="emacs? ( virtual/emacs )"
-RDEPEND="${DEPEND}"
+RDEPEND="emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
S="${WORKDIR}/${MY_PN}-${MY_PV}"
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
eapply "${FILESDIR}"/${P}-version.patch
+ eapply "${FILESDIR}"/${P}-yywrap.patch
eapply_user
eautoreconf
}
diff --git a/dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch b/dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch
new file mode 100644
index 000000000000..9d46a91beceb
--- /dev/null
+++ b/dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/604848
+
+--- intercal-0.30-orig/src/lexer.l
++++ intercal-0.30/src/lexer.l
+@@ -38,12 +38,10 @@
+ /*#undef wchar_t*/
+ /*#define wchar_t unsigned char*/
+
+-#ifndef yywrap
+ static int yywrap(void)
+ {
+ return 1;
+ }
+-#endif /* yywrap */
+
+ int iyylineno = 1;
+