summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/elixir/elixir-1.10.2.ebuild')
-rw-r--r--dev-lang/elixir/elixir-1.10.2.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-lang/elixir/elixir-1.10.2.ebuild b/dev-lang/elixir/elixir-1.10.2.ebuild
deleted file mode 100644
index 6db35bebc3c2..000000000000
--- a/dev-lang/elixir/elixir-1.10.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Elixir programming language"
-HOMEPAGE="https://elixir-lang.org"
-SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 ErlPL-1.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ~sparc x86"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-DEPEND="
- >=dev-lang/erlang-21:0=[ssl]
-"
-# 'mix' tool collides with sci-biology/phylip, bug #537514
-RDEPEND="${DEPEND}
- !!sci-biology/phylip
-"
-DEPEND+="
- test? ( dev-vcs/git )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
- "${FILESDIR}"/${P}-test-regex-fix.patch # backport
-)
-
-src_compile() {
- emake Q=""
-}
-
-src_install() {
- emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
- dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
-}