summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/icon/icon-9.5.1-r2.ebuild')
-rw-r--r--dev-lang/icon/icon-9.5.1-r2.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-lang/icon/icon-9.5.1-r2.ebuild b/dev-lang/icon/icon-9.5.1-r2.ebuild
index 5f313ed60aae..d76ac046eb3d 100644
--- a/dev-lang/icon/icon-9.5.1-r2.ebuild
+++ b/dev-lang/icon/icon-9.5.1-r2.ebuild
@@ -31,8 +31,13 @@ PATCHES=(
"${FILESDIR}"/${PN}-9.5.1-flags.patch
# https://bugs.gentoo.org/669330
# Fix glibc 2.28 problem.
- # Patch has also been submitted for upstream approval
+ # Patch has been accepted upstream, but is not yet in a release
"${FILESDIR}"/${PN}-9.5.1-fpoll.patch
+
+ # https://bugs.gentoo.org/716212
+ # Fix building with musl
+ # Patch has been accepted upstream, but is not yet in a release
+ "${FILESDIR}"/${PN}-9.5.1-musl.patch
)
src_prepare() {
@@ -61,8 +66,13 @@ src_configure() {
-e 's:-L/usr/X11R6/lib64::g' \
-e 's:-L/usr/X11R6/lib::g' \
-e 's:-I/usr/X11R6/include::g' \
+ -e 's:-I/usr/X11R6/include::g' \
+ -e '/^CFLAGS/d' \
Makedefs || die "sed of Makedefs failed"
+ if use elibc_musl; then
+ append-flags "-D_MUSL"
+ fi
append-flags $(test-flags -fno-strict-aliasing -fwrapv)
}