summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/julia/files/julia-9999-fix_build_system.patch')
-rw-r--r--dev-lang/julia/files/julia-9999-fix_build_system.patch43
1 files changed, 10 insertions, 33 deletions
diff --git a/dev-lang/julia/files/julia-9999-fix_build_system.patch b/dev-lang/julia/files/julia-9999-fix_build_system.patch
index 6f8041617751..d7866f46b3e0 100644
--- a/dev-lang/julia/files/julia-9999-fix_build_system.patch
+++ b/dev-lang/julia/files/julia-9999-fix_build_system.patch
@@ -1,5 +1,5 @@
diff --git a/Make.inc b/Make.inc
-index e30c150..e6fdbb2 100644
+index e77681669..bc17c6fd0 100644
--- a/Make.inc
+++ b/Make.inc
@@ -399,7 +399,7 @@ ifneq ($(OS), WINNT)
@@ -29,25 +29,8 @@ index e30c150..e6fdbb2 100644
endif
ifeq ($(USECCACHE), 1)
-diff --git a/deps/tools/jldownload b/deps/tools/jldownload
-index ab4fd69..e2c2408 100755
---- a/deps/tools/jldownload
-+++ b/deps/tools/jldownload
-@@ -5,9 +5,9 @@
-
- CACHE_HOST=https://cache.julialang.org
-
--WGET=$(which wget 2>/dev/null)
--CURL=$(which curl 2>/dev/null)
--FETCH=$(which fetch 2>/dev/null)
-+WGET=/bin/true
-+CURL=/bin/true
-+FETCH=/bin/true
-
- TIMEOUT=15 # seconds
- WGET_OPTS="--no-check-certificate --tries=1 --timeout=$TIMEOUT"
diff --git a/doc/Makefile b/doc/Makefile
-index 743804d..e06dde0 100644
+index 743804d8b..e06dde030 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -25,7 +25,7 @@ deps: UnicodeData.txt
@@ -60,28 +43,22 @@ index 743804d..e06dde0 100644
cleanall: clean
diff --git a/src/Makefile b/src/Makefile
-index f71f53d..7cdd23f 100644
+index d3ff98900..9c4d889b4 100644
--- a/src/Makefile
+++ b/src/Makefile
-@@ -85,20 +85,8 @@ PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLI
+@@ -87,14 +87,7 @@ PUBLIC_HEADERS += $(LIBUV_INC)/uv*
+ endif
+ PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLIC_HEADERS)))
- # In LLVM < 3.4, --ldflags includes both options and libraries, so use it both before and after --libs
- # In LLVM >= 3.4, --ldflags has only options, and --system-libs has the libraries.
+-# In LLVM < 3.4, --ldflags includes both options and libraries, so use it both before and after --libs
+-# In LLVM >= 3.4, --ldflags has only options, and --system-libs has the libraries.
-ifneq ($(USE_LLVM_SHLIB),1)
-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --libs $(LLVM_LIBS)) $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --system-libs 2> /dev/null)
-else
--ifeq ($(LLVM_USE_CMAKE),1)
-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM
--else
--ifeq ($(OS),WINNT)
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(LLVM_VER_SHORT)
--else
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(shell $(LLVM_CONFIG_HOST) --version)
--endif # OS == WINNT
--endif # LLVM_USE_CMAKE == 1
-+LLVMLINK = $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --libs) $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --system-libs)
- FLAGS += -DLLVM_SHLIB
+-FLAGS += -DLLVM_SHLIB
-endif # USE_LLVM_SHLIB == 1
++LLVMLINK = $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --libs) $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --system-libs)
COMMON_LIBS := -L$(build_shlibdir) -L$(build_libdir) $(LIBUV) $(LIBUTF8PROC) $(NO_WHOLE_ARCHIVE) $(LLVMLINK) $(OSLIBS)
DEBUG_LIBS := $(WHOLE_ARCHIVE) $(BUILDDIR)/flisp/libflisp-debug.a $(WHOLE_ARCHIVE) $(BUILDDIR)/support/libsupport-debug.a $(COMMON_LIBS)