summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/moarvm/moarvm-2015.05.ebuild')
-rw-r--r--dev-lang/moarvm/moarvm-2015.05.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lang/moarvm/moarvm-2015.05.ebuild b/dev-lang/moarvm/moarvm-2015.05.ebuild
new file mode 100644
index 000000000000..af545660fe2e
--- /dev/null
+++ b/dev-lang/moarvm/moarvm-2015.05.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+MY_PN="MoarVM"
+
+DESCRIPTION="A 6model-based VM for NQP and Rakudo Perl 6"
+HOMEPAGE="http://moarvm.org"
+SRC_URI="http://moarvm.org/releases/${MY_PN}-${PV}.tar.gz"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/libuv"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/MoarVM-${PV}"
+
+src_configure() {
+ perl Configure.pl --prefix="${D}/usr"|| die
+}
+
+src_install() {
+ emake install
+}