summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.7.18-r5.ebuild')
-rw-r--r--dev-lang/python/python-2.7.18-r5.ebuild22
1 files changed, 0 insertions, 22 deletions
diff --git a/dev-lang/python/python-2.7.18-r5.ebuild b/dev-lang/python/python-2.7.18-r5.ebuild
index 022e586961cc..66d18c69df18 100644
--- a/dev-lang/python/python-2.7.18-r5.ebuild
+++ b/dev-lang/python/python-2.7.18-r5.ebuild
@@ -65,7 +65,6 @@ DEPEND="${RDEPEND}
RDEPEND+="
!build? ( app-misc/mime-types )
!<=dev-lang/python-exec-2.4.6-r1"
-PDEPEND=">=app-eselect/eselect-python-20140125-r1"
pkg_setup() {
if use berkdb; then
@@ -346,24 +345,3 @@ src_install() {
dosym "python${PYVER}" "/usr/bin/python${pymajor}"
dosym "python${PYVER}-config" "/usr/bin/python${pymajor}-config"
}
-
-eselect_python_update() {
- if [[ -z "$(eselect python show)" || \
- ! -f "${EROOT}/usr/bin/$(eselect python show)" ]]; then
- eselect python update
- fi
-
- if [[ -z "$(eselect python show --python${PV%%.*})" || \
- ! -f "${EROOT}/usr/bin/$(eselect python show --python${PV%%.*})" ]]
- then
- eselect python update --python${PV%%.*}
- fi
-}
-
-pkg_postinst() {
- eselect_python_update
-}
-
-pkg_postrm() {
- eselect_python_update
-}