summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/typescript')
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-4.3.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index bcde372f400c..55260792f5a8 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1,2 +1,3 @@
DIST typescript-4.3.2.tgz 10624314 BLAKE2B b980fbabc60e143470d437a93247b874823353b7e7e9691b2a35abdfc2c5323fc7184f9ca8adca5211cebc329eac467900a7a54af8435e8955c8d76903a3f14a SHA512 cd9e214a19e69e8567007a551d6a5373176fedd58feb44b616cc9d40b57c5793db4b71627e3585151887496a4325a865cbcf0f472579b5e4d22e8ab8786ee62b
DIST typescript-4.3.4.tgz 10627952 BLAKE2B 41e6075569cf1d7221d414a141084e0afa1963198e47a4556e4efa331765dd5001f243bd8d84a9fcc69672c94b8946fc8931a0f9d1caac2245409f54a8bbd8cb SHA512 b9ab8f1bb5d99fd17f9a8fbb32bb118f2bdbc45a737a64632846574b800af37a0fd8a28e24fbdbfbd70efe09a7bfc6ab599be19e354e5f3ec1e3d9b59747bd13
+DIST typescript-4.3.5.tgz 10627908 BLAKE2B 8fda1e3c2ee052273e5fa22245a0af26c3171b93a5bd6d57453e92828748bec83ca9cef075b005e5b73f7be7e18210d0fef24c08e7b8054fd3c1d30376357d44 SHA512 0ea4208a1690f5c52bb24268f642325bffa0d15c6c93c703b59e766b734687460d4dfa54480ad74a88725069ef6cf6b310f2eedfdf02d14c662923ab3ee994cc
diff --git a/dev-lang/typescript/typescript-4.3.5.ebuild b/dev-lang/typescript/typescript-4.3.5.ebuild
new file mode 100644
index 000000000000..dcbc71b38d89
--- /dev/null
+++ b/dev-lang/typescript/typescript-4.3.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+DEPEND=""
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+S="${WORKDIR}/package"
+
+src_compile() {
+ # nothing to compile here
+ :
+}
+
+src_install() {
+ npm \
+ --audit false \
+ --color false \
+ --foreground-scripts \
+ --global \
+ --offline \
+ --omit dev \
+ --prefix "${ED}"/usr \
+ --progress false \
+ --verbose \
+ install "${DISTDIR}/${P}".tgz || die "npm install failed"
+
+ einstalldocs
+}