summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ats/metadata.xml2
-rw-r--r--dev-lang/bas/metadata.xml2
-rw-r--r--dev-lang/bff/metadata.xml1
-rw-r--r--dev-lang/crystal/metadata.xml2
-rw-r--r--dev-lang/elixir/metadata.xml4
-rw-r--r--dev-lang/ghc/metadata.xml8
-rw-r--r--dev-lang/go-bootstrap/metadata.xml2
-rw-r--r--dev-lang/gwydion-dylan-bin/metadata.xml1
-rw-r--r--dev-lang/icon/metadata.xml2
-rw-r--r--dev-lang/io/metadata.xml1
-rw-r--r--dev-lang/lazarus/metadata.xml2
-rw-r--r--dev-lang/logtalk/metadata.xml14
-rw-r--r--dev-lang/lua/metadata.xml2
-rw-r--r--dev-lang/luajit/metadata.xml3
-rw-r--r--dev-lang/mono-basic/metadata.xml1
-rw-r--r--dev-lang/mono/metadata.xml4
-rw-r--r--dev-lang/nasm/metadata.xml2
-rw-r--r--dev-lang/nqc/metadata.xml2
-rw-r--r--dev-lang/nwcc/metadata.xml2
-rw-r--r--dev-lang/perl/metadata.xml2
-rw-r--r--dev-lang/php/metadata.xml44
-rw-r--r--dev-lang/rakudo/metadata.xml4
-rw-r--r--dev-lang/spidermonkey/metadata.xml7
-rw-r--r--dev-lang/srf/metadata.xml1
-rw-r--r--dev-lang/swi-prolog/metadata.xml4
-rw-r--r--dev-lang/teyjus/metadata.xml2
-rw-r--r--dev-lang/tuprolog/metadata.xml2
-rw-r--r--dev-lang/whitespace/metadata.xml2
-rw-r--r--dev-lang/xsb/metadata.xml2
-rw-r--r--dev-lang/yap/metadata.xml2
30 files changed, 61 insertions, 68 deletions
diff --git a/dev-lang/ats/metadata.xml b/dev-lang/ats/metadata.xml
index b68ddd18967..2eec024d235 100644
--- a/dev-lang/ats/metadata.xml
+++ b/dev-lang/ats/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
diff --git a/dev-lang/bas/metadata.xml b/dev-lang/bas/metadata.xml
index 367faed79b4..6bc26420da8 100644
--- a/dev-lang/bas/metadata.xml
+++ b/dev-lang/bas/metadata.xml
@@ -5,6 +5,6 @@
<email>maintainer-needed@gentoo.org</email>
</maintainer>
<use>
- <flag name='lr0'>Use the LR0 parser instead of the recursive descending parser</flag>
+ <flag name="lr0">Use the LR0 parser instead of the recursive descending parser</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/bff/metadata.xml b/dev-lang/bff/metadata.xml
index 9e77c1fd69b..4f4825af6b0 100644
--- a/dev-lang/bff/metadata.xml
+++ b/dev-lang/bff/metadata.xml
@@ -9,4 +9,3 @@ bff is a slightly optimized interpreter for brainfuck, a turing-complete
programming language.
</longdescription>
</pkgmetadata>
-
diff --git a/dev-lang/crystal/metadata.xml b/dev-lang/crystal/metadata.xml
index a0e7647f368..7d958c4399b 100644
--- a/dev-lang/crystal/metadata.xml
+++ b/dev-lang/crystal/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>proxy-maintainers</herd>
diff --git a/dev-lang/elixir/metadata.xml b/dev-lang/elixir/metadata.xml
index d553c3568b7..33915315c6f 100644
--- a/dev-lang/elixir/metadata.xml
+++ b/dev-lang/elixir/metadata.xml
@@ -16,10 +16,10 @@
<changelog>
https://github.com/elixir-lang/elixir/blob/master/CHANGELOG.md
</changelog>
- <doc lang='en'>
+ <doc lang="en">
http://elixir-lang.org/docs.html
</doc>
- <remote-id type='github'>
+ <remote-id type="github">
elixir-lang/elixir
</remote-id>
</upstream>
diff --git a/dev-lang/ghc/metadata.xml b/dev-lang/ghc/metadata.xml
index 873a999955e..05bff5b45c4 100644
--- a/dev-lang/ghc/metadata.xml
+++ b/dev-lang/ghc/metadata.xml
@@ -3,9 +3,9 @@
<pkgmetadata>
<herd>haskell</herd>
<use>
- <flag name='binary'>Install the binary version directly, rather than using it to build the source version.</flag>
- <flag name='ghcbootstrap'>Bootstrap from an existing GHC installation.</flag>
- <flag name='ghcmakebinary'>Build with less runtime depends (bundle libffi for building bootstrap binaries).</flag>
- <flag name='llvm'>Enable llvm code generator for ghc (-fllvm).</flag>
+ <flag name="binary">Install the binary version directly, rather than using it to build the source version.</flag>
+ <flag name="ghcbootstrap">Bootstrap from an existing GHC installation.</flag>
+ <flag name="ghcmakebinary">Build with less runtime depends (bundle libffi for building bootstrap binaries).</flag>
+ <flag name="llvm">Enable llvm code generator for ghc (-fllvm).</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/go-bootstrap/metadata.xml b/dev-lang/go-bootstrap/metadata.xml
index afdfdb99076..1738abf651b 100644
--- a/dev-lang/go-bootstrap/metadata.xml
+++ b/dev-lang/go-bootstrap/metadata.xml
@@ -8,6 +8,6 @@
<longdescription lang="en">
This package is only necessary until gccgo supports go-1.4. It
will be removed as soon as stable gcc supports this.
- It is here so that >=dev-lang/go 1.5 can use it to bootstrap.
+ It is here so that &gt;=dev-lang/go 1.5 can use it to bootstrap.
</longdescription>
</pkgmetadata>
diff --git a/dev-lang/gwydion-dylan-bin/metadata.xml b/dev-lang/gwydion-dylan-bin/metadata.xml
index b757f0bd18f..9979a50623e 100644
--- a/dev-lang/gwydion-dylan-bin/metadata.xml
+++ b/dev-lang/gwydion-dylan-bin/metadata.xml
@@ -14,4 +14,3 @@ supports multiple inheritance, polymorphism, multiple dispatch, keyword
arguments, object introspection, and many other advanced features.
</longdescription>
</pkgmetadata>
-
diff --git a/dev-lang/icon/metadata.xml b/dev-lang/icon/metadata.xml
index 8595a9cf85b..69edcf2f577 100644
--- a/dev-lang/icon/metadata.xml
+++ b/dev-lang/icon/metadata.xml
@@ -2,5 +2,5 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>lang-misc</herd>
-<use><flag name='iplsrc'>install the icon programming library source</flag></use>
+<use><flag name="iplsrc">install the icon programming library source</flag></use>
</pkgmetadata>
diff --git a/dev-lang/io/metadata.xml b/dev-lang/io/metadata.xml
index 39a9737f1bb..056d4cc0dfb 100644
--- a/dev-lang/io/metadata.xml
+++ b/dev-lang/io/metadata.xml
@@ -24,4 +24,3 @@ concurrency), LISP (code is a runtime inspectable/modifiable tree) and Lua
(small, embeddable).
</longdescription>
</pkgmetadata>
-
diff --git a/dev-lang/lazarus/metadata.xml b/dev-lang/lazarus/metadata.xml
index 642a64ed7f2..f370d2ad439 100644
--- a/dev-lang/lazarus/metadata.xml
+++ b/dev-lang/lazarus/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>lang-misc</herd>
diff --git a/dev-lang/logtalk/metadata.xml b/dev-lang/logtalk/metadata.xml
index c314a540f62..ba56af5289a 100644
--- a/dev-lang/logtalk/metadata.xml
+++ b/dev-lang/logtalk/metadata.xml
@@ -3,12 +3,12 @@
<pkgmetadata>
<herd>prolog</herd>
<use>
- <flag name='gnupl'>Support GNU Prolog back-end compiler</flag>
- <flag name='qupl'>Support Qu-Prolog back-end compiler</flag>
- <flag name='swipl'>Support SWI-Prolog back-end compiler</flag>
- <flag name='xsbpl'>Support XSB back-end compiler</flag>
- <flag name='yappl'>Support YAP back-end compiler</flag>
- <flag name='xslt'>Support for generating html documentation using xslt</flag>
- <flag name='fop'>Support for generating pdf documentation using fop</flag>
+ <flag name="gnupl">Support GNU Prolog back-end compiler</flag>
+ <flag name="qupl">Support Qu-Prolog back-end compiler</flag>
+ <flag name="swipl">Support SWI-Prolog back-end compiler</flag>
+ <flag name="xsbpl">Support XSB back-end compiler</flag>
+ <flag name="yappl">Support YAP back-end compiler</flag>
+ <flag name="xslt">Support for generating html documentation using xslt</flag>
+ <flag name="fop">Support for generating pdf documentation using fop</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/lua/metadata.xml b/dev-lang/lua/metadata.xml
index cfb994f96a0..0120a42eff9 100644
--- a/dev-lang/lua/metadata.xml
+++ b/dev-lang/lua/metadata.xml
@@ -9,5 +9,5 @@
<email>rafaelmartins@gentoo.org</email>
<name>Rafael G. Martins</name>
</maintainer>
-<use><flag name='deprecated'>make deprecated data structures/routines available</flag></use>
+<use><flag name="deprecated">make deprecated data structures/routines available</flag></use>
</pkgmetadata>
diff --git a/dev-lang/luajit/metadata.xml b/dev-lang/luajit/metadata.xml
index e3ee128b8a2..5df84156b43 100644
--- a/dev-lang/luajit/metadata.xml
+++ b/dev-lang/luajit/metadata.xml
@@ -6,7 +6,7 @@
<name>Rafael G. Martins</name>
</maintainer>
<use>
- <flag name='lua52compat'>
+ <flag name="lua52compat">
Enable some upwards-compatible features
from Lua 5.2 that are unlikely to break existing code.
</flag>
@@ -15,4 +15,3 @@
LuaJIT is a Just-In-Time Compiler for the Lua programming language.
</longdescription>
</pkgmetadata>
-
diff --git a/dev-lang/mono-basic/metadata.xml b/dev-lang/mono-basic/metadata.xml
index 9b12b95d906..b678a425f91 100644
--- a/dev-lang/mono-basic/metadata.xml
+++ b/dev-lang/mono-basic/metadata.xml
@@ -6,4 +6,3 @@
Visual Basic .NET compiler and runtime
</longdescription>
</pkgmetadata>
-
diff --git a/dev-lang/mono/metadata.xml b/dev-lang/mono/metadata.xml
index 9529ca592b6..91e40e84f16 100644
--- a/dev-lang/mono/metadata.xml
+++ b/dev-lang/mono/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>dotnet</herd>
<use>
- <flag name='pax_kernel'>Enable if the user plans to run the package under a pax enabled hardened kernel</flag>
- <flag name='xen'>Make mono generate code that is considerably faster on xen VMs but slightly slower on for normal systems.</flag>
+ <flag name="pax_kernel">Enable if the user plans to run the package under a pax enabled hardened kernel</flag>
+ <flag name="xen">Make mono generate code that is considerably faster on xen VMs but slightly slower on for normal systems.</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/nasm/metadata.xml b/dev-lang/nasm/metadata.xml
index ebc02cb6bf0..0b7d2f1c37a 100644
--- a/dev-lang/nasm/metadata.xml
+++ b/dev-lang/nasm/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
diff --git a/dev-lang/nqc/metadata.xml b/dev-lang/nqc/metadata.xml
index 30bc973142b..7a3144873cd 100644
--- a/dev-lang/nqc/metadata.xml
+++ b/dev-lang/nqc/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
diff --git a/dev-lang/nwcc/metadata.xml b/dev-lang/nwcc/metadata.xml
index 42f4a82306a..0433b360b69 100644
--- a/dev-lang/nwcc/metadata.xml
+++ b/dev-lang/nwcc/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
diff --git a/dev-lang/perl/metadata.xml b/dev-lang/perl/metadata.xml
index 1f1398aeae6..50e60f019f5 100644
--- a/dev-lang/perl/metadata.xml
+++ b/dev-lang/perl/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>perl</herd>
<use>
- <flag name='ithreads'>Enable Perl threads, has some compatibility problems</flag>
+ <flag name="ithreads">Enable Perl threads, has some compatibility problems</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/php/metadata.xml b/dev-lang/php/metadata.xml
index 2224016d79d..395f6b538cf 100644
--- a/dev-lang/php/metadata.xml
+++ b/dev-lang/php/metadata.xml
@@ -3,27 +3,27 @@
<pkgmetadata>
<herd>php</herd>
<use>
- <flag name='cli'>Enable CLI SAPI</flag>
- <flag name='embed'>Enable embed SAPI</flag>
- <flag name='enchant'>Add supports Enchant spelling library.</flag>
- <flag name='fileinfo'>Add fileinfo extension support</flag>
- <flag name='filter'>Add filter extension support</flag>
- <flag name='fpm'>Enable the FastCGI Process Manager SAPI</flag>
- <flag name='gd'>Adds support for gd (bundled with PHP)</flag>
- <flag name='hash'>Enable the hash extension</flag>
- <flag name='json'>Enable JSON support</flag>
- <flag name='ldap-sasl'>Add SASL support for the PHP LDAP extension</flag>
- <flag name='mysqlnd'>Use native driver for mysql, mysqli, PDO_Mysql</flag>
- <flag name='libmysqlclient'>Use libmyslclient driver for mysql, mysqli, PDO_Mysql (not recommended)</flag>
- <flag name='intl'>Enables the intl extension for extended internalization support</flag>
- <flag name='opcache'>Enables built-in opcode cache, replacing pecl-apc et.al</flag>
- <flag name='pdo'>Enable the bundled PDO extensions</flag>
- <flag name='phar'>Enables the phar extension to provide phar archive support</flag>
- <flag name='phpdbg'>Enable the PHP Debug Command Line SAPI (like gdb for php)</flag>
- <flag name='xmlreader'>Enable XMLReader support</flag>
- <flag name='xmlwriter'>Enable XMLWriter support</flag>
- <flag name='xslt'>Enable the XSL extension</flag>
- <flag name='vpx'>Enable webp suppoprt for GD</flag>
- <flag name='zip'>Enable ZIP file support</flag>
+ <flag name="cli">Enable CLI SAPI</flag>
+ <flag name="embed">Enable embed SAPI</flag>
+ <flag name="enchant">Add supports Enchant spelling library.</flag>
+ <flag name="fileinfo">Add fileinfo extension support</flag>
+ <flag name="filter">Add filter extension support</flag>
+ <flag name="fpm">Enable the FastCGI Process Manager SAPI</flag>
+ <flag name="gd">Adds support for gd (bundled with PHP)</flag>
+ <flag name="hash">Enable the hash extension</flag>
+ <flag name="json">Enable JSON support</flag>
+ <flag name="ldap-sasl">Add SASL support for the PHP LDAP extension</flag>
+ <flag name="mysqlnd">Use native driver for mysql, mysqli, PDO_Mysql</flag>
+ <flag name="libmysqlclient">Use libmyslclient driver for mysql, mysqli, PDO_Mysql (not recommended)</flag>
+ <flag name="intl">Enables the intl extension for extended internalization support</flag>
+ <flag name="opcache">Enables built-in opcode cache, replacing pecl-apc et.al</flag>
+ <flag name="pdo">Enable the bundled PDO extensions</flag>
+ <flag name="phar">Enables the phar extension to provide phar archive support</flag>
+ <flag name="phpdbg">Enable the PHP Debug Command Line SAPI (like gdb for php)</flag>
+ <flag name="xmlreader">Enable XMLReader support</flag>
+ <flag name="xmlwriter">Enable XMLWriter support</flag>
+ <flag name="xslt">Enable the XSL extension</flag>
+ <flag name="vpx">Enable webp suppoprt for GD</flag>
+ <flag name="zip">Enable ZIP file support</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/rakudo/metadata.xml b/dev-lang/rakudo/metadata.xml
index 75666cc2c24..0e57a6b15f1 100644
--- a/dev-lang/rakudo/metadata.xml
+++ b/dev-lang/rakudo/metadata.xml
@@ -7,7 +7,7 @@
<name>Patrick Lauer</name>
</maintainer>
<use>
- <flag name='parrot'>Build the parrot backend (default)</flag>
- <flag name='moar'>Build the MoarVM backend (experimental)</flag>
+ <flag name="parrot">Build the parrot backend (default)</flag>
+ <flag name="moar">Build the MoarVM backend (experimental)</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/spidermonkey/metadata.xml b/dev-lang/spidermonkey/metadata.xml
index ec0cd3c674e..80d2507cd7d 100644
--- a/dev-lang/spidermonkey/metadata.xml
+++ b/dev-lang/spidermonkey/metadata.xml
@@ -6,9 +6,8 @@
Stand-alone JavaScript C library
</longdescription>
<use>
- <flag name='debug'>Enable assertions to allow for easier debugging of programs that link to spidermonkey -- note this will often crash software on regular end-user systems</flag>
- <flag name='threadsafe'>Build a threadsafe version of spidermonkey</flag>
- <flag name='system-icu'>Use the system-wide <pkg>dev-libs/icu</pkg> instead of bundled -- note, only takes effect when icu flag is enabled</flag>
+ <flag name="debug">Enable assertions to allow for easier debugging of programs that link to spidermonkey -- note this will often crash software on regular end-user systems</flag>
+ <flag name="threadsafe">Build a threadsafe version of spidermonkey</flag>
+ <flag name="system-icu">Use the system-wide <pkg>dev-libs/icu</pkg> instead of bundled -- note, only takes effect when icu flag is enabled</flag>
</use>
</pkgmetadata>
-
diff --git a/dev-lang/srf/metadata.xml b/dev-lang/srf/metadata.xml
index c0594a6b0e0..3da5928e6aa 100644
--- a/dev-lang/srf/metadata.xml
+++ b/dev-lang/srf/metadata.xml
@@ -11,4 +11,3 @@ similar to Stephen Kleene's recursive functions. You can use srf to help
understand recursive functions, or Peano arithmetic.
</longdescription>
</pkgmetadata>
-
diff --git a/dev-lang/swi-prolog/metadata.xml b/dev-lang/swi-prolog/metadata.xml
index 49e918fd205..88333bfa6e8 100644
--- a/dev-lang/swi-prolog/metadata.xml
+++ b/dev-lang/swi-prolog/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>prolog</herd>
<use>
- <flag name='archive'>Use libarchive for extension packs</flag>
- <flag name='uuid'>Use ossp-uuid for UUID pack</flag>
+ <flag name="archive">Use libarchive for extension packs</flag>
+ <flag name="uuid">Use ossp-uuid for UUID pack</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/teyjus/metadata.xml b/dev-lang/teyjus/metadata.xml
index e14550d0f53..47cb4971b74 100644
--- a/dev-lang/teyjus/metadata.xml
+++ b/dev-lang/teyjus/metadata.xml
@@ -5,7 +5,7 @@
<email>gienah@gentoo.org</email>
<name>Mark Wright</name>
</maintainer>
-<longdescription lang='en'>
+<longdescription lang="en">
The Teyjus system is an efficient implementation of the higher-order
logic programming language Lambda Prolog. The main strength of Lambda
Prolog, a language developed by Dale Miller and Gopalan Nadathur, is
diff --git a/dev-lang/tuprolog/metadata.xml b/dev-lang/tuprolog/metadata.xml
index 05a00456d24..7e53cf044c8 100644
--- a/dev-lang/tuprolog/metadata.xml
+++ b/dev-lang/tuprolog/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>prolog</herd>
diff --git a/dev-lang/whitespace/metadata.xml b/dev-lang/whitespace/metadata.xml
index 96f7e3fc1f3..57991c68fe7 100644
--- a/dev-lang/whitespace/metadata.xml
+++ b/dev-lang/whitespace/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>haskell</herd>
diff --git a/dev-lang/xsb/metadata.xml b/dev-lang/xsb/metadata.xml
index 299cf67f64b..1a3e7c07d1f 100644
--- a/dev-lang/xsb/metadata.xml
+++ b/dev-lang/xsb/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>prolog</herd>
diff --git a/dev-lang/yap/metadata.xml b/dev-lang/yap/metadata.xml
index 9720e3e3e80..f68e980f3d5 100644
--- a/dev-lang/yap/metadata.xml
+++ b/dev-lang/yap/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>prolog</herd>
<use>
- <flag name='R'>Enable support for connecting R to Prolog</flag>
+ <flag name="R">Enable support for connecting R to Prolog</flag>
</use>
</pkgmetadata>