summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/asmjit/asmjit-2022.07.02.ebuild')
-rw-r--r--dev-libs/asmjit/asmjit-2022.07.02.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/asmjit/asmjit-2022.07.02.ebuild b/dev-libs/asmjit/asmjit-2022.07.02.ebuild
new file mode 100644
index 000000000000..909111795e67
--- /dev/null
+++ b/dev-libs/asmjit/asmjit-2022.07.02.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+CommitId=c59847629d3a19da4d10f0be4ac33b43fc4a100f
+DESCRIPTION="Machine code generation for C++"
+HOMEPAGE="https://asmjit.com/"
+SRC_URI="https://github.com/asmjit/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+src_configure() {
+ mycmakeargs=(
+ -DASMJIT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}