summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest2
-rw-r--r--dev-libs/botan/botan-1.10.17-r2.ebuild160
-rw-r--r--dev-libs/botan/botan-2.11.0.ebuild102
-rw-r--r--dev-libs/botan/botan-2.14.0.ebuild102
4 files changed, 0 insertions, 366 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 337faaaec06e..ec1ecd8e0cb3 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,4 +1,2 @@
-DIST Botan-1.10.17.tgz 2706678 BLAKE2B bce65493c702381aaa747c2b935c545f85704b93bb6be4bf225048cc14812999291bbbe86786c2b00865489ec47d63128b12ef1020be8651be57fa1c84006a7c SHA512 a47cab3af113652247c8efc8b0f043eb62175eaa8554833d5fc3016ea94dbdd8aa722ab9b5226cc5f133afbcc088d54362111630eaa4594812c39925cc3c8649
-DIST Botan-2.11.0.tar.xz 5765712 BLAKE2B 5602ef9485363b21f6f622f7370e486d834477730c2fc2f0bb9211db944d2b2a6a03d8ae14845cf871f648c76c77fd3e18804bd598f805a5754e3bfadb114d5d SHA512 a697a7f29788afc561cde35431e65e2f37e40fd45af89a6d060bf9988d28089905c6a1c005f9b23fb377547cd7a96a41f62c8d2f61a7f80d1ca1b9ccf857a2ce
DIST Botan-2.14.0.tar.xz 5958948 BLAKE2B 90e73945b22f6e4e8d6163bfb45eca153eb1495448f8bf35514b780fd12bb1b81c822314e1f598c7625277f1e9cf7a6265387cca80ffd4c2664c681b9d4807fd SHA512 ee15928ecdb0127720b444b0207d46fd68fe3007125b0deb8bdd32f96e9befb684ad54009354da4f6a3c48b9698693b46223710a47fd644da8760dda53d40d34
DIST Botan-2.9.0.tgz 7216373 BLAKE2B 5ad2e15db871ccc3a32b29b7f54a02d69f251f0aca2ce656b557dbbb3814a793053a54905371b3414ad72952a64bece43e2383da91f205f68b0fe31be2f9439c SHA512 b88f3894a4a5b7b2fbff9be6eb0b774bf679a014bd2364811b7e63d4f323e22ca9ef916491afbc2cdf9db68727c1449fbeb6fd417e591560add0955517db3f65
diff --git a/dev-libs/botan/botan-1.10.17-r2.ebuild b/dev-libs/botan/botan-1.10.17-r2.ebuild
deleted file mode 100644
index 80af870a2c46..000000000000
--- a/dev-libs/botan/botan-1.10.17-r2.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit multilib python-r1 toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="https://botan.randombit.net/"
-SRC_URI="https://botan.randombit.net/releases/${MY_P}.tgz"
-
-KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~ppc-macos"
-SLOT="0"
-LICENSE="BSD"
-IUSE="bindist doc python bzip2 gmp libressl ssl static-libs threads zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="${DEPEND}
- bzip2? ( >=app-arch/bzip2-1.0.5 )
- zlib? ( >=sys-libs/zlib-1.2.3 )
- python? ( ${PYTHON_DEPS} >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}] )
- gmp? ( >=dev-libs/gmp-4.2.2:* )
- ssl? (
- !libressl? ( <dev-libs/openssl-1.1:0=[bindist=] )
- libressl? ( dev-libs/libressl:0= )
- )"
-BDEPEND="dev-lang/python:*
- doc? ( dev-python/sphinx )"
-
-PATCHES=(
- "${FILESDIR}/${P}-build.patch"
- "${FILESDIR}/${P}-libressl.patch"
-)
-
-src_prepare() {
- default
-
- sed -e "s/-Wl,-soname,\$@ //" -i src/build-data/makefile/python.in || die "sed failed"
- sed \
- -e "/DOCDIR/d" \
- -e "/^install:/s/ docs//" \
- -i src/build-data/makefile/unix_shr.in || die "sed failed"
-
- # Fix ImportError with Python 3.
- sed -e "s/_botan/.&/" -i src/wrap/python/__init__.py || die "sed failed"
-
- use python && python_copy_sources
-}
-
-src_configure() {
- local disable_modules="proc_walk,unix_procs"
- use threads || disable_modules+=",pthreads"
- use bindist && disable_modules+=",ecdsa"
- elog "Disabling modules: ${disable_modules}"
-
- # Enable v9 instructions for sparc64
- if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="${CHOST%%-*}"
- fi
-
- local myos=
- case ${CHOST} in
- *-darwin*) myos=darwin ;;
- *) myos=linux ;;
- esac
-
- # foobared buildsystem, --prefix translates into DESTDIR, see also make
- # install in src_install, we need the correct live-system prefix here on
- # Darwin for a shared lib with correct install_name
- ./configure.py \
- --prefix="${EPREFIX}/usr" \
- --libdir=$(get_libdir) \
- --docdir=share/doc \
- --cc=gcc \
- --os=${myos} \
- --cpu=${CHOSTARCH} \
- --with-endian="$(tc-endian)" \
- --without-sphinx \
- --with-tr1=system \
- $(use_with bzip2) \
- $(use_with gmp gnump) \
- $(use_with python boost-python) \
- $(use_with ssl openssl) \
- $(use_with zlib) \
- --disable-modules=${disable_modules} \
- || die "configure.py failed"
-}
-
-src_compile() {
- emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT=""
-
- if use python; then
- building() {
- rm -fr build/python
- ln -s "${BUILD_DIR}" build/python
- cp Makefile.python build/python
- sed -i \
- -e "s/-lboost_python/-lboost_python-$(echo ${EPYTHON} | sed 's/python//')/" \
- build/python/Makefile.python
- emake -f build/python/Makefile.python \
- CXX="$(tc-getCXX)" \
- CFLAGS="${CXXFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- PYTHON_ROOT="/usr/$(get_libdir)" \
- PYTHON_INC="-I$(python_get_includedir)"
- }
- python_foreach_impl building
- fi
-
- if use doc; then
- einfo "Generation of documentation"
- sphinx-build doc doc_output || die
- fi
-}
-
-src_test() {
- chmod -R ugo+rX "${S}"
- emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check
- LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
-}
-
-src_install() {
- emake DESTDIR="${ED}/usr" install
-
- if ! use static-libs; then
- rm "${ED}/usr/$(get_libdir)/libbotan"*.a || die 'remove of static libs failed'
- fi
-
- # Add compatibility symlinks.
- [[ -e "${ED}/usr/bin/botan-config" ]] && die "Compatibility code no longer needed"
- [[ -e "${ED}/usr/$(get_libdir)/pkgconfig/botan.pc" ]] && die "Compatibility code no longer needed"
- dosym botan-config-1.10 /usr/bin/botan-config
- dosym botan-1.10.pc /usr/$(get_libdir)/pkgconfig/botan.pc
-
- if use python; then
- installation() {
- rm -fr build/python
- ln -s "${BUILD_DIR}" build/python
- emake -f Makefile.python \
- PYTHON_SITE_PACKAGE_DIR="${D}$(python_get_sitedir)" \
- install
- }
- python_foreach_impl installation
- fi
-
- if use doc; then
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static
- popd > /dev/null
- fi
-}
diff --git a/dev-libs/botan/botan-2.11.0.ebuild b/dev-libs/botan/botan-2.11.0.ebuild
deleted file mode 100644
index 2b1b5bb66292..000000000000
--- a/dev-libs/botan/botan-2.11.0.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-MY_P="Botan-${PV}"
-inherit python-r1 toolchain-funcs
-
-DESCRIPTION="C++ crypto library"
-HOMEPAGE="https://botan.randombit.net/"
-SRC_URI="https://botan.randombit.net/releases/${MY_P}.tar.xz"
-
-LICENSE="BSD"
-SLOT="2/$(ver_cut 1-2)" # soname version
-KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~ppc-macos"
-IUSE="bindist bzip2 boost doc libressl lzma python sqlite ssl static-libs zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="${DEPEND}
- boost? ( >=dev-libs/boost-1.48:= )
- bzip2? ( >=app-arch/bzip2-1.0.5:= )
- lzma? ( app-arch/xz-utils:= )
- sqlite? ( dev-db/sqlite:3= )
- ssl? (
- !libressl? ( dev-libs/openssl:0=[bindist=] )
- libressl? ( dev-libs/libressl:0= )
- )
- zlib? ( >=sys-libs/zlib-1.2.3:= )
-"
-BDEPEND="
- dev-lang/python:*
- doc? ( dev-python/sphinx )
-"
-
-src_configure() {
- local disable_modules=()
- use boost || disable_modules+=( "boost" )
- use bindist && disable_modules+=( "ecdsa" )
- elog "Disabling modules: ${disable_modules[@]}"
-
- # Enable v9 instructions for sparc64
- if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="${CHOST%%-*}"
- fi
-
- local myos=
- case ${CHOST} in
- *-darwin*) myos=darwin ;;
- *) myos=linux ;;
- esac
-
- case ${CHOST} in
- hppa*) CHOSTARCH=parisc ;;
- esac
-
- local pythonvers=()
- if use python; then
- append() {
- pythonvers+=( ${EPYTHON/python/} )
- }
- python_foreach_impl append
- fi
-
- CXX="$(tc-getCXX)" AR="$(tc-getAR)" ./configure.py \
- $(use_enable static-libs static-library) \
- $(use_with boost) \
- $(use_with bzip2) \
- $(use_with doc documentation) \
- $(use_with doc sphinx) \
- $(use_with lzma) \
- $(use_with sqlite sqlite3) \
- $(use_with ssl openssl) \
- $(use_with zlib) \
- $(usex hppa --without-stack-protector '') \
- --cc=gcc \
- --cpu=${CHOSTARCH} \
- --disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
- --docdir=share/doc \
- --libdir=$(get_libdir) \
- --os=${myos} \
- --prefix="${EPREFIX}/usr" \
- --with-endian="$(tc-endian)" \
- --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
- --without-doxygen \
- || die "configure.py failed"
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
-}
-
-src_install() {
- default
- use python && python_foreach_impl python_optimize
-}
diff --git a/dev-libs/botan/botan-2.14.0.ebuild b/dev-libs/botan/botan-2.14.0.ebuild
deleted file mode 100644
index 6d2a94dea777..000000000000
--- a/dev-libs/botan/botan-2.14.0.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-MY_P="Botan-${PV}"
-inherit python-r1 toolchain-funcs
-
-DESCRIPTION="C++ crypto library"
-HOMEPAGE="https://botan.randombit.net/"
-SRC_URI="https://botan.randombit.net/releases/${MY_P}.tar.xz"
-
-LICENSE="BSD"
-SLOT="2/$(ver_cut 1-2)" # soname version
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~ppc-macos"
-IUSE="bindist bzip2 boost doc libressl lzma python sqlite ssl static-libs zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="${DEPEND}
- boost? ( >=dev-libs/boost-1.48:= )
- bzip2? ( >=app-arch/bzip2-1.0.5:= )
- lzma? ( app-arch/xz-utils:= )
- sqlite? ( dev-db/sqlite:3= )
- ssl? (
- !libressl? ( dev-libs/openssl:0=[bindist=] )
- libressl? ( dev-libs/libressl:0= )
- )
- zlib? ( >=sys-libs/zlib-1.2.3:= )
-"
-BDEPEND="
- dev-lang/python:*
- doc? ( dev-python/sphinx )
-"
-
-src_configure() {
- local disable_modules=()
- use boost || disable_modules+=( "boost" )
- use bindist && disable_modules+=( "ecdsa" )
- elog "Disabling modules: ${disable_modules[@]}"
-
- # Enable v9 instructions for sparc64
- if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="${CHOST%%-*}"
- fi
-
- local myos=
- case ${CHOST} in
- *-darwin*) myos=darwin ;;
- *) myos=linux ;;
- esac
-
- case ${CHOST} in
- hppa*) CHOSTARCH=parisc ;;
- esac
-
- local pythonvers=()
- if use python; then
- append() {
- pythonvers+=( ${EPYTHON/python/} )
- }
- python_foreach_impl append
- fi
-
- CXX="$(tc-getCXX)" AR="$(tc-getAR)" ./configure.py \
- $(use_enable static-libs static-library) \
- $(use_with boost) \
- $(use_with bzip2) \
- $(use_with doc documentation) \
- $(use_with doc sphinx) \
- $(use_with lzma) \
- $(use_with sqlite sqlite3) \
- $(use_with ssl openssl) \
- $(use_with zlib) \
- $(usex hppa --without-stack-protector '') \
- --cc=gcc \
- --cpu=${CHOSTARCH} \
- --disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
- --docdir=share/doc \
- --libdir=$(get_libdir) \
- --os=${myos} \
- --prefix="${EPREFIX}/usr" \
- --with-endian="$(tc-endian)" \
- --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
- --without-doxygen \
- || die "configure.py failed"
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
-}
-
-src_install() {
- default
- use python && python_foreach_impl python_optimize
-}