summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/c-siphash/c-siphash-1.1.0.ebuild')
-rw-r--r--dev-libs/c-siphash/c-siphash-1.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/c-siphash/c-siphash-1.1.0.ebuild b/dev-libs/c-siphash/c-siphash-1.1.0.ebuild
new file mode 100644
index 000000000000..5f8d92d5783f
--- /dev/null
+++ b/dev-libs/c-siphash/c-siphash-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Streaming-capable SipHash Implementation"
+HOMEPAGE="
+ https://c-util.github.io/c-siphash/
+ https://github.com/c-util/c-siphash/
+"
+SRC_URI="
+ https://github.com/c-util/c-siphash/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/c-stdaux-1.5.0
+"
+BDEPEND="
+ virtual/pkgconfig
+"