summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/cppcodec/cppcodec-0.2.ebuild')
-rw-r--r--dev-libs/cppcodec/cppcodec-0.2.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-libs/cppcodec/cppcodec-0.2.ebuild b/dev-libs/cppcodec/cppcodec-0.2.ebuild
index fe7a12a7e61f..ed1f2f4c8f3d 100644
--- a/dev-libs/cppcodec/cppcodec-0.2.ebuild
+++ b/dev-libs/cppcodec/cppcodec-0.2.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
inherit cmake-utils
DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
@@ -25,11 +24,8 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
- test? (
- virtual/pkgconfig
- >=dev-cpp/catch-2.3.0
- )"
+DEPEND="test? ( >=dev-cpp/catch-2.3.0:0 )"
+BDEPEND="test? ( virtual/pkgconfig )"
src_configure() {
local mycmakeargs=(