summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/distorm3')
-rw-r--r--dev-libs/distorm3/distorm3-3.5.2-r1.ebuild38
-rw-r--r--dev-libs/distorm3/distorm3-3.5.2.ebuild45
-rw-r--r--dev-libs/distorm3/metadata.xml1
3 files changed, 39 insertions, 45 deletions
diff --git a/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild b/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild
new file mode 100644
index 000000000000..2b29e61283f4
--- /dev/null
+++ b/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-lang/yasm )"
+
+PATCHES=( "${FILESDIR}"/${P}-under.patch )
+
+EPYTEST_DESELECT=(
+ # outdated tests? API usage mismatch
+ # https://github.com/gdabah/distorm/issues/173
+ python/test_distorm3.py::Test::test_dummy
+ python/test_distorm3.py::InstBin::test_dummy
+ python/test_distorm3.py::Inst::test_dummy
+)
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install
+
+ # don't know why it does not happen by default
+ python_optimize
+}
diff --git a/dev-libs/distorm3/distorm3-3.5.2.ebuild b/dev-libs/distorm3/distorm3-3.5.2.ebuild
deleted file mode 100644
index 50ac20c5ac09..000000000000
--- a/dev-libs/distorm3/distorm3-3.5.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9,10} )
-
-inherit distutils-r1
-
-DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
-HOMEPAGE="http://www.ragestorm.net/distorm/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-4"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-DEPEND=""
-RDEPEND=""
-BDEPEND="test? ( dev-lang/yasm )"
-
-distutils_enable_tests pytest
-
-PATCHES=("${FILESDIR}"/${P}-under.patch)
-
-python_install() {
- distutils-r1_python_install
-
- # don't know why it does not happen by default
- python_optimize
-}
-
-python_test() {
- local exclude=(
- # outdated tests? API udage mismatch
- # https://github.com/gdabah/distorm/issues/173
- python/test_distorm3.py::Test::test_dummy
- python/test_distorm3.py::InstBin::test_dummy
- python/test_distorm3.py::Inst::test_dummy
- )
- epytest ${exclude[@]/#/--deselect }
-}
diff --git a/dev-libs/distorm3/metadata.xml b/dev-libs/distorm3/metadata.xml
index 2ce0a2c00b34..228e23190a66 100644
--- a/dev-libs/distorm3/metadata.xml
+++ b/dev-libs/distorm3/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="github">gdabah/distorm</remote-id>
+ <remote-id type="pypi">distorm3</remote-id>
</upstream>
</pkgmetadata>