summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/elfio/elfio-1.0.3.ebuild')
-rw-r--r--dev-libs/elfio/elfio-1.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/elfio/elfio-1.0.3.ebuild b/dev-libs/elfio/elfio-1.0.3.ebuild
new file mode 100644
index 000000000000..042658c341e8
--- /dev/null
+++ b/dev-libs/elfio/elfio-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+MY_P=ELFIO-${PV}
+DESCRIPTION="ELF (Executable and Linkable Format) reader and producer implemented as a C++ library"
+HOMEPAGE="http://elfio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elfio/${MY_P}.tar.gz"
+
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-shared.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README
+}