summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/eventlog/eventlog-0.2.12.ebuild')
-rw-r--r--dev-libs/eventlog/eventlog-0.2.12.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/dev-libs/eventlog/eventlog-0.2.12.ebuild b/dev-libs/eventlog/eventlog-0.2.12.ebuild
index d886e06c86ad..63c44c31efbd 100644
--- a/dev-libs/eventlog/eventlog-0.2.12.ebuild
+++ b/dev-libs/eventlog/eventlog-0.2.12.ebuild
@@ -1,21 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit libtool eutils ltprune
+EAPI=7
+
+inherit libtool
DESCRIPTION="Support library for syslog-ng"
HOMEPAGE="http://www.balabit.com/products/syslog_ng/"
-SRC_URI="http://www.balabit.com/downloads/files/eventlog/0.2//eventlog_${PV}.tar.gz"
+SRC_URI="http://www.balabit.com/downloads/files/eventlog/$(ver_cut 1-2)/eventlog_${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~m68k-mint"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="static-libs"
-DEPEND=""
+DOCS=( AUTHORS CREDITS ChangeLog NEWS PORTS README )
src_prepare() {
+ default
+
elibtoolize
}
@@ -24,7 +27,7 @@ src_configure() {
}
src_install() {
- DOCS="AUTHORS CREDITS ChangeLog NEWS PORTS README" \
- default
- prune_libtool_files
+ default
+
+ find "${ED}" -name '*.la' -delete || die
}