summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild')
-rw-r--r--dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..97ad5484327a
--- /dev/null
+++ b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="Library for downloading files via HTTP using the GET method"
+HOMEPAGE="http://http-fetcher.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86"
+IUSE="debug"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-underquoted-http-fetcher-macro.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-strict \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ dodoc -r docs/html/*.html docs/index.html README ChangeLog CREDITS INSTALL
+
+ find "${ED}" -name '*.la' -delete || die
+}