summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/jsoncpp/jsoncpp-1.9.1.ebuild')
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.9.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/jsoncpp/jsoncpp-1.9.1.ebuild b/dev-libs/jsoncpp/jsoncpp-1.9.1.ebuild
index 6211be16019b..49dd145bbeaa 100644
--- a/dev-libs/jsoncpp/jsoncpp-1.9.1.ebuild
+++ b/dev-libs/jsoncpp/jsoncpp-1.9.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
DESCRIPTION="C++ JSON reader and writer"
HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
@@ -49,11 +49,11 @@ src_configure() {
# Disable implicit ccache use
-DCCACHE_FOUND=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc; then
cp "${BUILD_DIR}"/version . || die
@@ -63,5 +63,5 @@ src_compile() {
}
src_test() {
- cmake-utils_src_make jsoncpp_check
+ cmake_build jsoncpp_check
}