summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libarcus')
-rw-r--r--dev-libs/libarcus/Manifest1
-rw-r--r--dev-libs/libarcus/libarcus-3.3.0.ebuild42
-rw-r--r--dev-libs/libarcus/libarcus-3.5.1.ebuild42
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-libs/libarcus/Manifest b/dev-libs/libarcus/Manifest
index d697b5ee818a..6b335ca00ad4 100644
--- a/dev-libs/libarcus/Manifest
+++ b/dev-libs/libarcus/Manifest
@@ -1,4 +1,3 @@
-DIST libarcus-3.3.0.tar.gz 29695 BLAKE2B a63ca06133cf7db556fe82cc7ea060badd7838d697822d64e09c52aaa81a8509bfa6010037004593da3b1e66dde510767a992524f8e1719e614932b88b9393fe SHA512 a911fb5784ceb835ba2c175ce42cc10544bdd0834e987d8ac1be2517293f00e596f94910d8bf5f37f61e63246ba6e78d28a23bc061809e70b1bb6ad1a21107c9
DIST libarcus-3.4.1.tar.gz 29699 BLAKE2B 73f132ff9d908468f1d67c54b7430ac84c0aebb5dd12282dc894b877a91da3f9822e4db8bf16cb53f313396598d3890be9e06e50737b0a50edfc84543285f251 SHA512 63ed8d8da389641b91ed955624c04ca5488f98d3ef409c4a94ad1962155d6aedd8d61ca0231543cfe4e92ae10beb00001f957eb48f74b0c21447a1bd9b66d85d
DIST libarcus-3.5.1.tar.gz 28935 BLAKE2B ae850a0923e45446f248fb9944cd795cfa07e05ae4a1c0c91089fd60711603cb1c7b6c3ec81e71496e1a5a2752abb215cbcf725be65a0f8ca92dd0c9d24ed3f1 SHA512 a3cf8599aee83aa080d23849c2c9760e1342fd738db58f4e4bb974a9c3f3dfa34dab1fead6292aa6e27ad9a659fda7b92f031c141039bc3118df8f97cc4b8712
DIST libarcus-3.6.0.tar.gz 29469 BLAKE2B c032dd51631b10c04e69dac4425c8a5d180cf8c983b896330b2dcd5d479467d6a2e94827ef8accad25399167457e5ae9e96f1a363c986be33de8255c3e80b1fb SHA512 1bc50a08cbec61edefd78f3c347cca08f6bc40a308472bf6788c2c8962b03ea81b32357be18a3c34847c121eb52ee6836da22cea65b1a8f64b7c924bda290430
diff --git a/dev-libs/libarcus/libarcus-3.3.0.ebuild b/dev-libs/libarcus/libarcus-3.3.0.ebuild
deleted file mode 100644
index d0e49ef66b98..000000000000
--- a/dev-libs/libarcus/libarcus-3.3.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit cmake-utils python-single-r1
-
-MY_PN="libArcus"
-
-DESCRIPTION="This library facilitates communication between Cura and its backend"
-HOMEPAGE="https://github.com/Ultimaker/libArcus"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/3"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/sip[${PYTHON_USEDEP}]
- dev-libs/protobuf
- python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_PYTHON=$(usex python ON OFF)
- -DBUILD_EXAMPLES=$(usex examples ON OFF)
- -DBUILD_STATIC=$(usex static-libs ON OFF)
- )
- use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
- cmake-utils_src_configure
-}
diff --git a/dev-libs/libarcus/libarcus-3.5.1.ebuild b/dev-libs/libarcus/libarcus-3.5.1.ebuild
deleted file mode 100644
index 3714aa3353b2..000000000000
--- a/dev-libs/libarcus/libarcus-3.5.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit cmake-utils python-single-r1
-
-MY_PN="libArcus"
-
-DESCRIPTION="This library facilitates communication between Cura and its backend"
-HOMEPAGE="https://github.com/Ultimaker/libArcus"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/3"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/sip[${PYTHON_USEDEP}]
- dev-libs/protobuf
- python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_PYTHON=$(usex python ON OFF)
- -DBUILD_EXAMPLES=$(usex examples ON OFF)
- -DBUILD_STATIC=$(usex static-libs ON OFF)
- )
- use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
- cmake-utils_src_configure
-}