summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdnet')
-rw-r--r--dev-libs/libdnet/Manifest2
-rw-r--r--dev-libs/libdnet/libdnet-1.12.ebuild71
-rw-r--r--dev-libs/libdnet/metadata.xml8
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/libdnet/Manifest b/dev-libs/libdnet/Manifest
new file mode 100644
index 000000000000..ad547671ffca
--- /dev/null
+++ b/dev-libs/libdnet/Manifest
@@ -0,0 +1,2 @@
+DIST libdnet-1.12.ipv6-1.patch.gz 5124 SHA256 5e646901ae13d8aa47f0c5c063b86ecccb90780f9e3734cdbabf7a2d472c39ac SHA512 fa2380e41548ecdd978722930ecf90dffabd15cf06cbae0e113285072fe98a066f1e686b6d79e2d8b9f8adcf29783f313d61933b9e1e74e71da8dc7d741f815a WHIRLPOOL 27f356053749e1abdab24bd420f22e380e0970f7a2926474482a2e2532d1d8561f4b48d0eb243b5a62777543b3644adafd3cead4cc09f21d6cb5391a0b7e00f2
+DIST libdnet-1.12.tgz 970125 SHA256 83b33039787cf99990e977cef7f18a5d5e7aaffc4505548a83d31bd3515eb026 SHA512 b763d2caa77b8d16b531142a5bce3b862ed20198406a00e1fe7f3b45ce308b97d638b0c7f03bd8593fdd206cc1645952839bc340b77537298a3df88599835bf3 WHIRLPOOL 9e5b3a217bfef840ca0ed936dbc3573e51a9283a5a7d3ffd43606b98e8760586196261f34a2508cdcf9f868ccd08c9fd1d499252c9a43bb2f71a5b7b2c00c13e
diff --git a/dev-libs/libdnet/libdnet-1.12.ebuild b/dev-libs/libdnet/libdnet-1.12.ebuild
new file mode 100644
index 000000000000..f4231c4fe534
--- /dev/null
+++ b/dev-libs/libdnet/libdnet-1.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AT_M4DIR="config"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit autotools distutils-r1 eutils
+
+DESCRIPTION="simplified, portable interface to several low-level networking routines"
+HOMEPAGE="http://code.google.com/p/libdnet/"
+SRC_URI="http://libdnet.googlecode.com/files/${P}.tgz
+ ipv6? ( http://fragroute-ipv6.googlecode.com/files/${P}.ipv6-1.patch.gz )"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="ipv6 python static-libs test"
+
+#DEPEND="test? ( dev-libs/check )"
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+RESTRICT="test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS=( README THANKS TODO )
+
+src_prepare() {
+ # Useless copy
+ rm -r trunk/ || die
+
+ sed -i \
+ -e 's/libcheck.a/libcheck.so/g' \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.in || die
+ sed -i -e 's|-L@libdir@ ||g' dnet-config.in || die
+ use ipv6 && epatch "${WORKDIR}/${P}.ipv6-1.patch"
+ sed -i -e '/^SUBDIRS/s|python||g' Makefile.am || die
+ eautoreconf
+ if use python; then
+ cd python
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with python) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ if use python; then
+ cd python
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ default
+ if use python; then
+ cd python
+ unset DOCS
+ distutils-r1_src_install
+ fi
+ prune_libtool_files
+}
diff --git a/dev-libs/libdnet/metadata.xml b/dev-libs/libdnet/metadata.xml
new file mode 100644
index 000000000000..fb093adfd4cc
--- /dev/null
+++ b/dev-libs/libdnet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="google-code">libdnet</remote-id>
+ </upstream>
+</pkgmetadata>