summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/files/3.36.1-autoskip-network-test.patch30
-rw-r--r--dev-libs/libgweather/libgweather-3.36.1.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libgweather/files/3.36.1-autoskip-network-test.patch b/dev-libs/libgweather/files/3.36.1-autoskip-network-test.patch
new file mode 100644
index 000000000000..d6b3d2f61313
--- /dev/null
+++ b/dev-libs/libgweather/files/3.36.1-autoskip-network-test.patch
@@ -0,0 +1,30 @@
+From f2bacee194ce58aabf5a08752556177bda6ab570 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 30 Aug 2020 10:35:13 +0300
+Subject: [PATCH] tests: Skip metar tests when METAR_SOURCES couldn't be
+ resolved
+
+---
+ libgweather/test_libgweather.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/libgweather/test_libgweather.c b/libgweather/test_libgweather.c
+index 8a21911..ef401f8 100644
+--- a/libgweather/test_libgweather.c
++++ b/libgweather/test_libgweather.c
+@@ -419,6 +419,12 @@ test_metar_weather_stations (void)
+ msg = soup_message_new ("GET", METAR_SOURCES);
+ session = soup_session_new ();
+ soup_session_send_message (session, msg);
++ if (msg->status_code == SOUP_STATUS_CANT_RESOLVE) {
++ g_test_skip ("Could not resolve " METAR_SOURCES " - network sandboxed?");
++ g_object_unref (session);
++ g_object_unref (msg);
++ return;
++ }
+ g_assert (SOUP_STATUS_IS_SUCCESSFUL (msg->status_code));
+ g_object_unref (session);
+ g_assert_nonnull (msg->response_body);
+--
+2.20.1
+
diff --git a/dev-libs/libgweather/libgweather-3.36.1.ebuild b/dev-libs/libgweather/libgweather-3.36.1.ebuild
index 0db353126e43..ae7a41a1cc99 100644
--- a/dev-libs/libgweather/libgweather-3.36.1.ebuild
+++ b/dev-libs/libgweather/libgweather-3.36.1.ebuild
@@ -41,6 +41,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/3.32.1-meson-tweaks.patch # Provide introspection optionality and don't build tests that aren't ran automatically
"${FILESDIR}"/3.36.1-tests-locale.patch # Don't fail tests when a locale is not present, https://gitlab.gnome.org/GNOME/libgweather/-/merge_requests/58
+ "${FILESDIR}"/3.36.1-autoskip-network-test.patch
)
src_prepare() {