summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnsfb/files/libnsfb-0.1.3-glibc2.20.patch')
-rw-r--r--dev-libs/libnsfb/files/libnsfb-0.1.3-glibc2.20.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-libs/libnsfb/files/libnsfb-0.1.3-glibc2.20.patch b/dev-libs/libnsfb/files/libnsfb-0.1.3-glibc2.20.patch
new file mode 100644
index 000000000000..8d6ba888b0f4
--- /dev/null
+++ b/dev-libs/libnsfb/files/libnsfb-0.1.3-glibc2.20.patch
@@ -0,0 +1,19 @@
+--- libnsfb-0.1.3/Makefile
++++ libnsfb-0.1.3/Makefile
+@@ -15,13 +15,13 @@
+ # Toolchain flags
+ WARNFLAGS := -Wall -Wextra -Wundef -Wpointer-arith -Wcast-align \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+- -Wmissing-declarations -Wnested-externs -Werror
++ -Wmissing-declarations -Wnested-externs
+
+ # would like these flags but gcc earlier than 4.4 fail
+ #-pedantic -Wno-overlength-strings # For nsglobe.c
+
+-CFLAGS := -g -std=c99 -D_BSD_SOURCE -D_POSIX_C_SOURCE=200112L \
+- -I$(CURDIR)/include/ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS) -Wno-error
++CFLAGS := -std=c99 -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200112L \
++ -I$(CURDIR)/include/ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
+
+ NSFB_XCB_PKG_NAMES := xcb xcb-icccm xcb-image xcb-keysyms xcb-atom
+