summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libratbag/libratbag-0.16.ebuild')
-rw-r--r--dev-libs/libratbag/libratbag-0.16.ebuild27
1 files changed, 19 insertions, 8 deletions
diff --git a/dev-libs/libratbag/libratbag-0.16.ebuild b/dev-libs/libratbag/libratbag-0.16.ebuild
index b46974b3385e..ad08ddd3c6db 100644
--- a/dev-libs/libratbag/libratbag-0.16.ebuild
+++ b/dev-libs/libratbag/libratbag-0.16.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_10 )
inherit meson python-single-r1 systemd udev
@@ -25,26 +25,33 @@ BDEPEND="
${PYTHON_DEPS}
dev-lang/swig
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ ')
+ )
test? (
dev-libs/check
dev-libs/gobject-introspection
- dev-util/valgrind
+ dev-debug/valgrind
$(python_gen_cond_dep '
+ dev-python/evdev[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-evdev[${PYTHON_USEDEP}]
')
)
"
RDEPEND="
${PYTHON_DEPS}
acct-group/plugdev
+ dev-libs/glib:2
dev-libs/json-glib
dev-libs/libevdev
- virtual/libudev
+ dev-libs/libunistring:=
+ virtual/libudev:=
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/evdev[${PYTHON_USEDEP}]
')
elogind? ( sys-auth/elogind )
systemd? ( sys-apps/systemd )
@@ -54,6 +61,10 @@ DEPEND="
dev-libs/gobject-introspection
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.16-musl-error.h.patch
+)
+
src_prepare() {
default