summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libsodium/libsodium-1.0.15-r1.ebuild')
-rw-r--r--dev-libs/libsodium/libsodium-1.0.15-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-libs/libsodium/libsodium-1.0.15-r1.ebuild b/dev-libs/libsodium/libsodium-1.0.15-r1.ebuild
deleted file mode 100644
index ae0419e4c365..000000000000
--- a/dev-libs/libsodium/libsodium-1.0.15-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils autotools
-
-DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
-HOMEPAGE="https://github.com/jedisct1/libsodium"
-SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/23"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+asm minimal static-libs +urandom cpu_flags_x86_sse4_1 cpu_flags_x86_aes"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.0.10-cpuflags.patch )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf
-
- # --disable-pie needed on x86, bug #512734
- use x86 && myconf="${myconf} --disable-pie"
- # --disable-ssp is needed on musl x86
- use x86 && use elibc_musl && myconf+="${myconf} --disable-ssp"
-
- econf \
- $(use_enable asm) \
- $(use_enable minimal) \
- $(use_enable !urandom blocking-random) \
- $(use_enable static-libs static) \
- $(use_enable cpu_flags_x86_sse4_1 sse4_1) \
- $(use_enable cpu_flags_x86_aes aesni) \
- ${myconf}
-}
-
-src_install() {
- default
- prune_libtool_files
-}