summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libvarlink/libvarlink-22.ebuild')
-rw-r--r--dev-libs/libvarlink/libvarlink-22.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libvarlink/libvarlink-22.ebuild b/dev-libs/libvarlink/libvarlink-22.ebuild
new file mode 100644
index 000000000000..07f1b8cf52c7
--- /dev/null
+++ b/dev-libs/libvarlink/libvarlink-22.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="C implementation of the Varlink protocol and command line tool"
+HOMEPAGE="https://github.com/varlink/libvarlink"
+SRC_URI="https://github.com/varlink/libvarlink/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT+=" test"
+
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local emesonargs=(
+ -Dtests="$(usex test true false)"
+ )
+ meson_src_configure
+}