summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/link-grammar/link-grammar-5.3.3.ebuild')
-rw-r--r--dev-libs/link-grammar/link-grammar-5.3.3.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-libs/link-grammar/link-grammar-5.3.3.ebuild b/dev-libs/link-grammar/link-grammar-5.3.3.ebuild
deleted file mode 100644
index dbbbfc4efa8f..000000000000
--- a/dev-libs/link-grammar/link-grammar-5.3.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit eutils gnome2 java-pkg-opt-2 python-any-r1
-
-DESCRIPTION="A Syntactic English parser"
-HOMEPAGE="http://www.abisource.com/projects/link-grammar/ http://www.link.cs.cmu.edu/link/"
-SRC_URI="https://github.com/opencog/${PN}/archive/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-IUSE="aspell +hunspell +java python static-libs threads"
-
-DEPEND="
- aspell? ( app-text/aspell )
- hunspell? ( app-text/hunspell )
- java? ( >=virtual/jdk-1.6:=
- dev-java/ant-core )
- ${PYTHON_DEPS}"
-
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use java; then
- java-pkg-opt-2_pkg_setup
- fi
- if use aspell && use hunspell; then
- ewarn "You have enabled 'aspell' and 'hunspell' support, but both cannot coexist,"
- ewarn "only aspell will be build. Press Ctrl+C and set only 'hunspell' USE flag if"
- ewarn "you want hunspell support."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- S=${WORKDIR}/${PN}-${P}
-}
-
-src_prepare() {
- if use java; then
- java-pkg-opt-2_src_prepare
- fi
- ./autogen.sh || die
-}
-
-src_configure() {
- local myconf
-
- use hunspell && myconf="${myconf} --with-hunspell-dictdir=/usr/share/myspell"
- gnome2_src_configure \
- --enable-shared \
- $(use_enable aspell) \
- $(use_enable hunspell) \
- $(use_enable java java-bindings) \
- $(use_enable python python-bindings) \
- $(use_enable static-libs static) \
- $(use_enable threads pthreads) \
- ${myconf}
-}