summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/msgpack')
-rw-r--r--dev-libs/msgpack/files/msgpack-1.1.0-gcc6.patch22
-rw-r--r--dev-libs/msgpack/msgpack-1.1.0.ebuild6
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-libs/msgpack/files/msgpack-1.1.0-gcc6.patch b/dev-libs/msgpack/files/msgpack-1.1.0-gcc6.patch
new file mode 100644
index 000000000000..2fc9bb46e4bf
--- /dev/null
+++ b/dev-libs/msgpack/files/msgpack-1.1.0-gcc6.patch
@@ -0,0 +1,22 @@
+Bug: https://bugs.gentoo.org/623492
+Backported from: https://github.com/msgpack/msgpack-c/commit/66a5fcf8f1a9e57b02904a6ac55a86a9c74ea1de
+
+--- a/include/msgpack/adaptor/detail/cpp11_msgpack_tuple.hpp
++++ b/include/msgpack/adaptor/detail/cpp11_msgpack_tuple.hpp
+@@ -46,13 +46,14 @@
+ public:
+ using base = std::tuple<Types...>;
+
+- using base::base;
+
+- tuple() = default;
+ tuple(tuple const&) = default;
+ tuple(tuple&&) = default;
+
+ template<typename... OtherTypes>
++ tuple(OtherTypes&&... other):base(std::forward<OtherTypes>(other)...) {}
++
++ template<typename... OtherTypes>
+ tuple(tuple<OtherTypes...> const& other):base(static_cast<std::tuple<OtherTypes...> const&>(other)) {}
+ template<typename... OtherTypes>
+ tuple(tuple<OtherTypes...> && other):base(static_cast<std::tuple<OtherTypes...> &&>(other)) {}
diff --git a/dev-libs/msgpack/msgpack-1.1.0.ebuild b/dev-libs/msgpack/msgpack-1.1.0.ebuild
index e9316807c0c3..0743ad515c86 100644
--- a/dev-libs/msgpack/msgpack-1.1.0.ebuild
+++ b/dev-libs/msgpack/msgpack-1.1.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
inherit cmake-multilib
if [[ ${PV} == 9999 ]]; then
@@ -27,9 +28,11 @@ DEPEND="
"
DOCS=( README.md )
+
PATCHES=(
"${FILESDIR}"/${PN}-1.0.0-cflags.patch
"${FILESDIR}"/${PN}-1.0.0-static.patch
+ "${FILESDIR}"/${P}-gcc6.patch
)
src_configure() {
@@ -38,5 +41,6 @@ src_configure() {
$(cmake-utils_use static-libs MSGPACK_STATIC)
$(cmake-utils_use test MSGPACK_BUILD_TESTS)
)
+
cmake-multilib_src_configure
}