summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ntl/ntl-11.4.4.ebuild')
-rw-r--r--dev-libs/ntl/ntl-11.4.4.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/ntl/ntl-11.4.4.ebuild b/dev-libs/ntl/ntl-11.4.4.ebuild
index 0a9584119e17..18f21afb1eb0 100644
--- a/dev-libs/ntl/ntl-11.4.4.ebuild
+++ b/dev-libs/ntl/ntl-11.4.4.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="High-performance and portable C++ number theory library"
@@ -54,8 +55,11 @@ src_configure() {
src_install() {
default
+
if ! use static-libs; then
- rm "${ED}/usr/$(get_libdir)"/libntl.{la,a} || die
+ # bug #775884
+ find "${ED}" -name '*.la' -delete || die
+ rm "${ED}/usr/$(get_libdir)"/libntl.a || die
fi
rm -r "${ED}"/usr/share/doc/NTL || die