summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ptexenc')
-rw-r--r--dev-libs/ptexenc/Manifest1
-rw-r--r--dev-libs/ptexenc/ptexenc-1.3.9_p20210325.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/ptexenc/Manifest b/dev-libs/ptexenc/Manifest
index c815e7a77a07..c3d8bd659d3a 100644
--- a/dev-libs/ptexenc/Manifest
+++ b/dev-libs/ptexenc/Manifest
@@ -1 +1,2 @@
DIST texlive-20200406-source.tar.xz 55383320 BLAKE2B 3bc024166ebfc269389531c7cf818b062856cd2dcc27cf0a2e790f07cd941d9905c9c6a54566ea627ea1ca334d2b6da8d3e5bd1c686dc9d6f8ac15aac388c1e3 SHA512 65be52cb5e1b52f12feb62c6cf23e56c581b9dccb8d3b9ccc85c12c62b0cb67dd71de8d22d967d2cbf8403502c66bccb238523d13a0d081be104fc9f9c68b477
+DIST texlive-20210325-source.tar.xz 54837368 BLAKE2B 66bd4bdd43ff53513004b9b9b90ababa0ab5efcf183a27864a3d39cde9cf90721456bda90c49ad6014f4b12d2e6293feaf9a8b152b85a89ffaa96bf5056347df SHA512 afd6eb24efaeac7c58d43ff24162aece919079a9ae02934509f068c7a3828223c33c14d9db11ff7fea3560b08a06f352446ba7f845eefb4a56a87b96f088f213
diff --git a/dev-libs/ptexenc/ptexenc-1.3.9_p20210325.ebuild b/dev-libs/ptexenc/ptexenc-1.3.9_p20210325.ebuild
new file mode 100644
index 000000000000..94d3676e1748
--- /dev/null
+++ b/dev-libs/ptexenc/ptexenc-1.3.9_p20210325.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit libtool
+
+DESCRIPTION="Library for Japanese pTeX providing a better way of handling character encodings"
+HOMEPAGE="http://tutimura.ath.cx/ptexlive/?ptexenc"
+SRC_URI="https://dev.gentoo.org/~zlogene/distfiles/texlive/texlive-${PV#*_p}-source.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos"
+IUSE="iconv static-libs"
+
+DEPEND="iconv? ( virtual/libiconv )
+ dev-libs/kpathsea"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=377141
+ sed -i '/^LIBS/s:@LIBS@:@LIBS@ @KPATHSEA_LIBS@:' "${S}"/Makefile.in || die
+
+ cd "${WORKDIR}/texlive-${PV#*_p}-source"
+ S="${WORKDIR}/texlive-${PV#*_p}-source" elibtoolize #sane .so versionning on gfbsd
+}
+
+src_configure() {
+ econf \
+ --with-system-kpathsea \
+ $(use_enable static-libs static) \
+ $(use_enable iconv kanji-iconv)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ insinto /usr/include/ptexenc
+ doins ptexenc/unicode-jp.h
+ use iconv && doins ptexenc/kanjicnv.h
+
+ dodoc ChangeLog README
+}