summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/pugixml/pugixml-1.12.ebuild')
-rw-r--r--dev-libs/pugixml/pugixml-1.12.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/pugixml/pugixml-1.12.ebuild b/dev-libs/pugixml/pugixml-1.12.ebuild
new file mode 100644
index 000000000000..dd62094ec7ee
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.12.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml"
+
+LICENSE="MIT"
+SLOT="0"