summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/raft')
-rw-r--r--dev-libs/raft/Manifest3
-rw-r--r--dev-libs/raft/files/raft-0.11.3-disable-automagic-check-for-lz4.patch79
-rw-r--r--dev-libs/raft/metadata.xml2
-rw-r--r--dev-libs/raft/raft-0.18.0.ebuild (renamed from dev-libs/raft/raft-0.17.1.ebuild)3
-rw-r--r--dev-libs/raft/raft-0.18.2.ebuild57
5 files changed, 61 insertions, 83 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
index 41a25caa352f..8754e1f65c16 100644
--- a/dev-libs/raft/Manifest
+++ b/dev-libs/raft/Manifest
@@ -1 +1,2 @@
-DIST raft-0.17.1.tar.gz 354331 BLAKE2B d1be3eb4139422dab8126879d2ba0782e8635a60ce9752f4389f79dd2238021d9679d3b5f799c9627921c954a4395cdff139ff41f8145ebc43190f2c4aa3e5a7 SHA512 20e2b4a144a597b77bcb31e8b22355725142b14fb50e20b33509e7b0dd10aa20d08501b66e836c659e9aa492184db71ea9e53a45fe4b908b1464eb94431154db
+DIST raft-0.18.0.tar.gz 365558 BLAKE2B 57fc8c144a45eb101f53c8dd3a1eb896c733b7c5c369300852bea1474b8178b46c943c29e81107758bfa527d8fc1a9c80c4ca1bfc599dfc5ace090a18c693f11 SHA512 c6ab125a4841c5241310ea9785bb6ae3860c0a2ff39487499c2caa0b387729f7f7e54fa0de3aad3a99bdf5ec7d4a12c68a69244c6d8b8dcdf846c1cdfeb11b3b
+DIST raft-0.18.2.tar.gz 335089 BLAKE2B 5e6221f3977a28b7c2bbc8b80e047b455b586b0c8dd3cb9dc31f43c48d745d017f8a7220f3b3072a7aabacb86751ea4ad02f7c00d9d9c59a419354416cca65b3 SHA512 bac167aaf02f121f6d5de9103b366591bdb0a40ee08bc20b9f4fadae4606631b1a8dec514009596601a79a91c63373c524ba59710a167a1259f1d3802fb1e341
diff --git a/dev-libs/raft/files/raft-0.11.3-disable-automagic-check-for-lz4.patch b/dev-libs/raft/files/raft-0.11.3-disable-automagic-check-for-lz4.patch
deleted file mode 100644
index 7cd81e53cea9..000000000000
--- a/dev-libs/raft/files/raft-0.11.3-disable-automagic-check-for-lz4.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index e0dbfc8..e595cb7 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -80,7 +80,9 @@ libraft_la_LDFLAGS += $(LZ4_LIBS)
- endif # LZ4_AVAILABLE
- if LZ4_ENABLED
- test_unit_core_CFLAGS += -DLZ4_ENABLED
-+test_unit_core_LDFLAGS = $(LZ4_LIBS)
- libraft_la_CFLAGS += -DLZ4_ENABLED
-+libraft_la_LDFLAGS += $(LZ4_LIBS)
- endif # LZ4_ENABLED
-
- if FIXTURE_ENABLED
-@@ -210,6 +212,7 @@ test_integration_uv_LDFLAGS += $(LZ4_LIBS)
- endif # LZ4_AVAILABLE
- if LZ4_ENABLED
- test_integration_uv_CFLAGS += -DLZ4_ENABLED
-+test_integration_uv_LDFLAGS += $(LZ4_LIBS)
- endif # LZ4_ENABLED
-
- endif # UV_ENABLED
-diff --git a/configure.ac b/configure.ac
-index df7bea9..0e2949f 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -23,47 +23,13 @@ AM_CONDITIONAL(UV_ENABLED, test "x$have_uv" = "xyes")
- # explicitly disabled.
- AC_ARG_ENABLE(lz4, AS_HELP_STRING([--disable-lz4], [do not use lz4 compression]))
-
--# Thanks to the OpenVPN configure.ac file for this part.
--# If this fails, we will do another test next.
--# We also add set LZ4_LIBS otherwise linker will not know about the lz4 library
--PKG_CHECK_MODULES(LZ4, [liblz4 >= 1.7.1], [have_lz4="yes"], [LZ4_LIBS="-llz4"])
--if test "${have_lz4}" != "yes" ; then
-- AC_CHECK_HEADERS([lz4.h],
-- [have_lz4h="yes"],
-- [])
-- if test "${have_lz4h}" = "yes" ; then
-- AC_MSG_CHECKING([additionally if system LZ4 version >= 1.7.1])
-- AC_COMPILE_IFELSE(
-- [AC_LANG_PROGRAM([[
--#include <lz4.h>
-- ]],
-- [[
--/* Version encoding: MMNNPP (Major miNor Patch) - see lz4.h for details */
--#if LZ4_VERSION_NUMBER < 10701L
--#error LZ4 is too old
--#endif
-- ]]
-- )],
-- [
-- AC_MSG_RESULT([ok])
-- have_lz4="yes"
-- ],
-- [
-- AC_MSG_RESULT([system LZ4 library is too old])
-- have_lz4="no"
-- ]
-- )
-- fi
--fi
--
--AS_IF([test "x$enable_lz4" != "xno" -a "x$have_lz4" != "xyes"],
-- [AC_MSG_ERROR([liblz4 required but not found])], [])
--# LZ4 Can be available without being enabled, this allows a user to activate
--# it at a later stage through an API call.
--AM_CONDITIONAL(LZ4_AVAILABLE, test "x$have_lz4" = "xyes")
-+AS_IF([test "x$enable_lz4" != "xno"], [
-+ PKG_CHECK_MODULES(LZ4, [liblz4 >= 1.7.1], [LZ4_LIBS="-llz4"])
-+])
- # `LZ4_ENABLED` will cause the libuv snapshot implementation to use lz4
- # compression by default.
--AM_CONDITIONAL(LZ4_ENABLED, test "x$enable_lz4" != "xno" -a "x$have_lz4" = "xyes")
-+AM_CONDITIONAL(LZ4_ENABLED, test "x$enable_lz4" != "xno")
-+AM_CONDITIONAL(LZ4_AVAILABLE, test "x$enable_lz4" != "xno")
-
- # The fake I/O implementation and associated fixture is built by default, unless
- # explicitly disabled.
diff --git a/dev-libs/raft/metadata.xml b/dev-libs/raft/metadata.xml
index fc7c392c0349..94076382bb1e 100644
--- a/dev-libs/raft/metadata.xml
+++ b/dev-libs/raft/metadata.xml
@@ -20,6 +20,6 @@
snapshots).
</longdescription>
<upstream>
- <remote-id type="github">canonical/raft</remote-id>
+ <remote-id type="github">cowsql/raft</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-libs/raft/raft-0.17.1.ebuild b/dev-libs/raft/raft-0.18.0.ebuild
index ffdfab60dd65..814ea73198f5 100644
--- a/dev-libs/raft/raft-0.17.1.ebuild
+++ b/dev-libs/raft/raft-0.18.0.ebuild
@@ -22,7 +22,6 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
- "${FILESDIR}"/raft-0.11.3-disable-automagic-check-for-lz4.patch
)
src_prepare() {
@@ -41,9 +40,9 @@ src_configure() {
--disable-sanitize
--disable-static
- $(use_enable lz4)
$(use_enable test fixture)
+ $(use_with lz4)
$(use_with zfs)
)
diff --git a/dev-libs/raft/raft-0.18.2.ebuild b/dev-libs/raft/raft-0.18.2.ebuild
new file mode 100644
index 000000000000..d576a08a3ca8
--- /dev/null
+++ b/dev-libs/raft/raft-0.18.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/cowsql/raft"
+SRC_URI="https://github.com/cowsql/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+
+# Upstream change from canonical to cowsql resetted SONAME, 3 -> 0. bgo#915960
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="lz4 test zfs"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv:=
+ lz4? ( app-arch/lz4:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-uv
+
+ --disable-backtrace
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable test fixture)
+
+ $(use_with lz4)
+ $(use_with zfs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}