summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rccl/files/rccl-5.0.2-change_install_location.patch')
-rw-r--r--dev-libs/rccl/files/rccl-5.0.2-change_install_location.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/rccl/files/rccl-5.0.2-change_install_location.patch b/dev-libs/rccl/files/rccl-5.0.2-change_install_location.patch
new file mode 100644
index 000000000000..11e3fea312de
--- /dev/null
+++ b/dev-libs/rccl/files/rccl-5.0.2-change_install_location.patch
@@ -0,0 +1,31 @@
+Index: rccl-rocm-5.0.2/CMakeLists.txt
+===================================================================
+--- rccl-rocm-5.0.2.orig/CMakeLists.txt
++++ rccl-rocm-5.0.2/CMakeLists.txt
+@@ -268,16 +268,12 @@ target_link_libraries(rccl INTERFACE hip
+ rocm_set_soversion(rccl "1.0")
+
+ rocm_install_targets(TARGETS
+- rccl
+- PREFIX
+ rccl)
+ rocm_install(FILES ${PROJECT_BINARY_DIR}/rccl.h
+- DESTINATION rccl/${CMAKE_INSTALL_INCLUDEDIR})
++ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+ rocm_export_targets(NAMESPACE
+ roc::
+- PREFIX
+- rccl
+ TARGETS
+ rccl
+ DEPENDS
+@@ -329,8 +325,6 @@ rocm_create_package(
+ "RCCL Maintainer <rccl-maintainer@amd.com>"
+ LDCONFIG)
+
+-rocm_install_symlink_subdir(rccl)
+-
+ if(BUILD_TESTS)
+ add_subdirectory(test)
+ endif()