summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/squareball/squareball-9999.ebuild')
-rw-r--r--dev-libs/squareball/squareball-9999.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/dev-libs/squareball/squareball-9999.ebuild b/dev-libs/squareball/squareball-9999.ebuild
index aeb29384561f..28dcbab67e2f 100644
--- a/dev-libs/squareball/squareball-9999.ebuild
+++ b/dev-libs/squareball/squareball-9999.ebuild
@@ -1,22 +1,17 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
- inherit git-r3 autotools
+ inherit autotools git-r3
fi
-inherit eutils ltprune
-
DESCRIPTION="A general-purpose library for C99"
HOMEPAGE="https://github.com/rafaelmartins/squareball"
-
-SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi
@@ -25,14 +20,11 @@ SLOT="0"
IUSE="doc test static-libs"
RESTRICT="!test? ( test )"
-RDEPEND=""
-
-DEPEND="
+BDEPEND="
virtual/pkgconfig
- test? (
- dev-util/cmocka )
- doc? (
- app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+"
+DEPEND="test? ( dev-util/cmocka )"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
@@ -55,5 +47,6 @@ src_compile() {
src_install() {
use doc && HTML_DOCS=( doc/build/html/* )
default
- prune_libtool_files --all
+
+ find "${ED}" -name '*.la' -delete || die
}