summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/stp/stp-2.3.3.ebuild')
-rw-r--r--dev-libs/stp/stp-2.3.3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/stp/stp-2.3.3.ebuild b/dev-libs/stp/stp-2.3.3.ebuild
index a900384b2178..69e3d1b92d74 100644
--- a/dev-libs/stp/stp-2.3.3.ebuild
+++ b/dev-libs/stp/stp-2.3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Simple Theorem Prover, an efficient SMT solver for bitvectors"
HOMEPAGE="https://stp.github.io/"
@@ -23,7 +23,7 @@ src_prepare() {
# replace static lib with $(get_libdir)
sed -i "s/set(LIBDIR lib/set(LIBDIR $(get_libdir)/" CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -33,11 +33,11 @@ src_configure() {
-DENABLE_PYTHON_INTERFACE="$(usex python)"
-DSTATICCOMPILE="$(usex static)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# don't install to /usr/man
doman "${D}/usr/man/man1/stp.1"